summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2015-11-13 16:54:49 +0100
committersirlucjan2015-11-13 16:54:49 +0100
commitccd7cc2266226fd59a5b0093bc26c969bf4d2a86 (patch)
tree532cad234d03994316063aacd8f3f7fdad7f3112
parent712143f38df28de7bc0aea1118923c7169629b5d (diff)
downloadaur-ccd7cc2266226fd59a5b0093bc26c969bf4d2a86.tar.gz
Bump to 4.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--nvidia-340xx-lqx.install2
-rw-r--r--nvidia-4.3-build.patch20
4 files changed, 38 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 943ad6b9215f..db958562bce6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = nvidia-340xx-lqx
pkgdesc = NVIDIA drivers for linux-lqx, 340xx legacy branch
pkgver = 340.93
- pkgrel = 4
+ pkgrel = 6
url = http://www.nvidia.com/
install = nvidia-340xx-lqx.install
arch = i686
arch = x86_64
license = custom
- makedepends = linux-lqx-headers>=4.2
- makedepends = linux-lqx-headers<4.3
- depends = linux-lqx>=4.2
- depends = linux-lqx<4.3
+ makedepends = linux-lqx-headers>=4.3
+ makedepends = linux-lqx-headers<4.4
+ depends = linux-lqx>=4.3
+ depends = linux-lqx<4.4
depends = nvidia-340xx-libgl
depends = nvidia-340xx-utils=340.93
conflicts = nvidia-lqx
conflicts = nvidia-304xx-lqx
options = !strip
source = nv-drm.patch
+ source = nvidia-4.3-build.patch
md5sums = 2365f1405f0c7bbb8f8cd7ebd5e4e301
+ md5sums = e400a8c538afd490726941d8c69b2c2d
source_i686 = ftp://download.nvidia.com/XFree86/Linux-x86/340.93/NVIDIA-Linux-x86-340.93.run
md5sums_i686 = 4a7edf6838a80c77a57fb6f6ec7f0437
source_x86_64 = ftp://download.nvidia.com/XFree86/Linux-x86_64/340.93/NVIDIA-Linux-x86_64-340.93-no-compat32.run
diff --git a/PKGBUILD b/PKGBUILD
index 20c8114fb750..1ac93fe91a4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,23 @@
pkgname=nvidia-340xx-lqx
pkgver=340.93
-_extramodules=extramodules-4.2-lqx
-pkgrel=4
+_extramodules=extramodules-4.3-lqx
+pkgrel=6
pkgdesc="NVIDIA drivers for linux-lqx, 340xx legacy branch"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-lqx>=4.2' 'linux-lqx<4.3' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
-makedepends=('linux-lqx-headers>=4.2' 'linux-lqx-headers<4.3')
+depends=('linux-lqx>=4.3' 'linux-lqx<4.4' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
+makedepends=('linux-lqx-headers>=4.3' 'linux-lqx-headers<4.4')
conflicts=('nvidia-lqx' 'nvidia-304xx-lqx')
license=('custom')
install=${pkgname}.install
options=(!strip)
-source=("nv-drm.patch")
+source=("nv-drm.patch"
+ 'nvidia-4.3-build.patch')
source_i686=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64=("ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums=('2365f1405f0c7bbb8f8cd7ebd5e4e301')
+md5sums=('2365f1405f0c7bbb8f8cd7ebd5e4e301'
+ 'e400a8c538afd490726941d8c69b2c2d')
md5sums_i686=('4a7edf6838a80c77a57fb6f6ec7f0437')
md5sums_x86_64=('cb80e3f1cb6f2fb6e6eab35fad0884e4')
@@ -28,7 +30,8 @@ md5sums_x86_64=('cb80e3f1cb6f2fb6e6eab35fad0884e4')
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
- patch -Np0 -i "$srcdir/nv-drm.patch"
+ patch -Np0 -i "$srcdir/nv-drm.patch"
+ patch -Np1 -i "$srcdir/nvidia-4.3-build.patch"
}
build() {
diff --git a/nvidia-340xx-lqx.install b/nvidia-340xx-lqx.install
index 015c44b150dd..a968d572b8c7 100644
--- a/nvidia-340xx-lqx.install
+++ b/nvidia-340xx-lqx.install
@@ -1,5 +1,5 @@
post_install() {
- EXTRAMODULES='extramodules-4.2-lqx'
+ EXTRAMODULES='extramodules-4.3-lqx'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
echo 'In order to use nvidia module, reboot the system.'
}
diff --git a/nvidia-4.3-build.patch b/nvidia-4.3-build.patch
new file mode 100644
index 000000000000..0bc539497ebd
--- /dev/null
+++ b/nvidia-4.3-build.patch
@@ -0,0 +1,20 @@
+--- a/kernel/nv-procfs.c
++++ b/kernel/nv-procfs.c
+@@ -360,7 +360,8 @@ nv_procfs_read_registry(
+ registry_keys = ((nvl != NULL) ?
+ nvl->registry_keys : nv_registry_keys);
+
+- return seq_printf(s, "Binary: \"%s\"\n", registry_keys);
++ seq_printf(s, "Binary: \"%s\"\n", registry_keys);
++ return 0;
+ }
+
+ static ssize_t
+@@ -560,7 +561,8 @@ nv_procfs_read_text_file(
+ void *v
+ )
+ {
+- return seq_puts(s, s->private);
++ seq_puts(s, s->private);
++ return 0;
+ }