summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2017-08-17 12:29:30 +0200
committersirlucjan2017-08-17 12:29:30 +0200
commite579a27a929b1f9a3c0f0b26394826aa19d64485 (patch)
tree16367ec99fe58d630600ef39e7e89d5cc0f8eac3
parent934314dcbafc9f0f9fa705f8307f500dc174bd81 (diff)
downloadaur-e579a27a929b1f9a3c0f0b26394826aa19d64485.tar.gz
Bump to 4.12.8-1
-rw-r--r--.SRCINFO18
-rw-r--r--4.11.0_kernel.patch (renamed from unfuck_4.11_for_340xx.patch)0
-rw-r--r--4.12.0_kernel.patch98
-rw-r--r--PKGBUILD22
-rw-r--r--nvidia-340xx-lqx.install2
5 files changed, 120 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ced03aa7ac9..ed737374b58b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
pkgbase = nvidia-340xx-lqx
pkgdesc = NVIDIA 340xx drivers for linux-lqx.
pkgver = 340.102
- pkgrel = 3
+ pkgrel = 4
url = http://www.nvidia.com/
install = nvidia-340xx-lqx.install
arch = i686
arch = x86_64
license = custom
- makedepends = linux-lqx-headers>=4.11
- makedepends = linux-lqx-headers<4.12
- depends = linux-lqx>=4.11
- depends = linux-lqx<4.12
+ makedepends = linux-lqx-headers>=4.12
+ makedepends = linux-lqx-headers<4.13
+ depends = linux-lqx>=4.12
+ depends = linux-lqx<4.13
depends = nvidia-340xx-libgl
depends = nvidia-340xx-utils=340.102
conflicts = nvidia-lqx
conflicts = nvidia-304xx-lqx
options = !strip
- source = 4.10.0_kernel.patch
source = fs52243.patch
- source = unfuck_4.11_for_340xx.patch
- sha256sums = b47c308d486dd777617d4195fa928091b677e4fca421b487328fab9932bc6222
+ source = 4.10.0_kernel.patch
+ source = 4.11.0_kernel.patch
+ source = 4.12.0_kernel.patch
sha256sums = d1741377218e512063434c52a62a4fe3cfb23ab0a0ebc9fc817567692541e73e
+ sha256sums = b47c308d486dd777617d4195fa928091b677e4fca421b487328fab9932bc6222
sha256sums = 72641410ba81af1dfbc8397434dc68a43a9f6ce9ac1b9dfe2beeacb6cbdc98bb
+ sha256sums = 210b7dc26b4f86933d96ab4da6e73d055dfcaa9e1f80eba8f3feb8f6d5ec7750
source_i686 = http://us.download.nvidia.com/XFree86/Linux-x86/340.102/NVIDIA-Linux-x86-340.102.run
sha256sums_i686 = 61b13d5dae0f6f5d788a4d8c4c98e8d971d19cb90b606058060d007946248828
source_x86_64 = http://us.download.nvidia.com/XFree86/Linux-x86_64/340.102/NVIDIA-Linux-x86_64-340.102-no-compat32.run
diff --git a/unfuck_4.11_for_340xx.patch b/4.11.0_kernel.patch
index 5ee3e4f04b59..5ee3e4f04b59 100644
--- a/unfuck_4.11_for_340xx.patch
+++ b/4.11.0_kernel.patch
diff --git a/4.12.0_kernel.patch b/4.12.0_kernel.patch
new file mode 100644
index 000000000000..095a1fc2a8ba
--- /dev/null
+++ b/4.12.0_kernel.patch
@@ -0,0 +1,98 @@
+diff -Naur NVIDIA-Linux-x86_64-340.102-old/kernel/conftest.sh NVIDIA-Linux-x86_64-340.102-new/kernel/conftest.sh
+--- NVIDIA-Linux-x86_64-340.102-old/kernel/conftest.sh 2017-01-16 21:15:32.000000000 +0100
++++ NVIDIA-Linux-x86_64-340.102-new/kernel/conftest.sh 2017-07-05 20:58:45.283333334 +0200
+@@ -362,7 +362,11 @@
+ # Determine if the set_memory_uc() function is present.
+ #
+ CODE="
+- #include <asm/cacheflush.h>
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++ #else
++ #include <asm/cacheflush.h>
++ #endif
+ void conftest_set_memory_uc(void) {
+ set_memory_uc();
+ }"
+@@ -375,7 +379,11 @@
+ # Determine if the set_memory_array_uc() function is present.
+ #
+ CODE="
+- #include <asm/cacheflush.h>
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++ #else
++ #include <asm/cacheflush.h>
++ #endif
+ void conftest_set_memory_array_uc(void) {
+ set_memory_array_uc();
+ }"
+@@ -388,7 +396,11 @@
+ # Determine if the set_pages_uc() function is present.
+ #
+ CODE="
+- #include <asm/cacheflush.h>
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++ #else
++ #include <asm/cacheflush.h>
++ #endif
+ void conftest_set_pages_uc(void) {
+ set_pages_uc();
+ }"
+diff -Naur NVIDIA-Linux-x86_64-340.102-old/kernel/nv-vm.c NVIDIA-Linux-x86_64-340.102-new/kernel/nv-vm.c
+--- NVIDIA-Linux-x86_64-340.102-old/kernel/nv-vm.c 2017-01-16 21:15:32.000000000 +0100
++++ NVIDIA-Linux-x86_64-340.102-new/kernel/nv-vm.c 2017-07-05 20:58:45.286666667 +0200
+@@ -13,6 +13,10 @@
+ #include "nv.h"
+ #include "nv-linux.h"
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++#endif
++
+ static inline void nv_set_contig_memory_uc(nv_pte_t *page_ptr, NvU32 num_pages)
+ {
+ if (nv_update_memory_types)
+diff -Naur NVIDIA-Linux-x86_64-340.102-old/kernel/uvm/conftest.sh NVIDIA-Linux-x86_64-340.102-new/kernel/uvm/conftest.sh
+--- NVIDIA-Linux-x86_64-340.102-old/kernel/uvm/conftest.sh 2017-01-16 21:15:33.000000000 +0100
++++ NVIDIA-Linux-x86_64-340.102-new/kernel/uvm/conftest.sh 2017-07-05 20:58:45.286666667 +0200
+@@ -362,7 +362,11 @@
+ # Determine if the set_memory_uc() function is present.
+ #
+ CODE="
+- #include <asm/cacheflush.h>
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++ #else
++ #include <asm/cacheflush.h>
++ #endif
+ void conftest_set_memory_uc(void) {
+ set_memory_uc();
+ }"
+@@ -375,7 +379,11 @@
+ # Determine if the set_memory_array_uc() function is present.
+ #
+ CODE="
+- #include <asm/cacheflush.h>
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++ #else
++ #include <asm/cacheflush.h>
++ #endif
+ void conftest_set_memory_array_uc(void) {
+ set_memory_array_uc();
+ }"
+@@ -388,7 +396,11 @@
+ # Determine if the set_pages_uc() function is present.
+ #
+ CODE="
+- #include <asm/cacheflush.h>
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++ #else
++ #include <asm/cacheflush.h>
++ #endif
+ void conftest_set_pages_uc(void) {
+ set_pages_uc();
+ }"
diff --git a/PKGBUILD b/PKGBUILD
index 08e0c77c6758..8ce64cf7824f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,25 @@
pkgname=nvidia-340xx-lqx
pkgver=340.102
-_extramodules=extramodules-4.11-lqx
-pkgrel=3
+_extramodules=extramodules-4.12-lqx
+pkgrel=4
_pkgdesc="NVIDIA 340xx drivers for linux-lqx."
pkgdesc="$_pkgdesc"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-lqx>=4.11' 'linux-lqx<4.12' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
-makedepends=('linux-lqx-headers>=4.11' 'linux-lqx-headers<4.12')
+depends=('linux-lqx>=4.12' 'linux-lqx<4.13' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
+makedepends=('linux-lqx-headers>=4.12' 'linux-lqx-headers<4.13')
conflicts=('nvidia-lqx' 'nvidia-304xx-lqx')
license=('custom')
install=nvidia-340xx-lqx.install
options=(!strip)
-source=('4.10.0_kernel.patch'
-'fs52243.patch'
-'unfuck_4.11_for_340xx.patch')
+source=('fs52243.patch' '4.10.0_kernel.patch' '4.11.0_kernel.patch' '4.12.0_kernel.patch')
source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha256sums=('b47c308d486dd777617d4195fa928091b677e4fca421b487328fab9932bc6222'
- 'd1741377218e512063434c52a62a4fe3cfb23ab0a0ebc9fc817567692541e73e'
- '72641410ba81af1dfbc8397434dc68a43a9f6ce9ac1b9dfe2beeacb6cbdc98bb')
+sha256sums=('d1741377218e512063434c52a62a4fe3cfb23ab0a0ebc9fc817567692541e73e'
+ 'b47c308d486dd777617d4195fa928091b677e4fca421b487328fab9932bc6222'
+ '72641410ba81af1dfbc8397434dc68a43a9f6ce9ac1b9dfe2beeacb6cbdc98bb'
+ '210b7dc26b4f86933d96ab4da6e73d055dfcaa9e1f80eba8f3feb8f6d5ec7750')
sha256sums_i686=('61b13d5dae0f6f5d788a4d8c4c98e8d971d19cb90b606058060d007946248828')
sha256sums_x86_64=('6a36bd9a0033769ecd11ce2aa60aeb41b50b20616c43fd19c55e027c451f585e')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
@@ -34,9 +33,10 @@ prepare() {
cd "${_pkg}"
# patches here
- patch -Np1 -i "${srcdir}"/unfuck_4.11_for_340xx.patch
patch -Np0 < "${srcdir}"/fs52243.patch
patch -Np1 < "${srcdir}"/4.10.0_kernel.patch
+ patch -Np1 < "${srcdir}"/4.11.0_kernel.patch
+ patch -Np1 < "${srcdir}"/4.12.0_kernel.patch
cp -a kernel kernel-dkms
}
diff --git a/nvidia-340xx-lqx.install b/nvidia-340xx-lqx.install
index 1fb0c284bae4..d4a2fa6b9184 100644
--- a/nvidia-340xx-lqx.install
+++ b/nvidia-340xx-lqx.install
@@ -1,5 +1,5 @@
post_install() {
- EXTRAMODULES='extramodules-4.11-lqx'
+ EXTRAMODULES='extramodules-4.12-lqx'
depmod $(cat /usr/lib/modules/${EXTRAMODULES}/version)
echo 'In order to use nvidia module, reboot the system.'
}