summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2016-06-08 13:03:30 +0200
committersirlucjan2016-06-08 13:03:30 +0200
commitf47544464dee7bb13ad1bde73b52833779a69d9b (patch)
tree9207f859d948d5efc647518acd9deddcd1dd9c3c
parenta7e10dc0c2a9113410993a24e1e853f5a8689721 (diff)
downloadaur-f47544464dee7bb13ad1bde73b52833779a69d9b.tar.gz
Bump to 4.5.7-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--linux-4.6.patch150
-rw-r--r--nvidia-340xx-lqx.install2
4 files changed, 168 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cf7f01c4a4d..17b43e0d6c8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Apr 15 10:37:47 UTC 2016
+# Wed Jun 8 11:03:30 UTC 2016
pkgbase = nvidia-340xx-lqx
pkgdesc = NVIDIA drivers for linux-lqx, 340xx legacy branch
pkgver = 340.96
@@ -9,15 +9,17 @@ pkgbase = nvidia-340xx-lqx
arch = i686
arch = x86_64
license = custom
- makedepends = linux-lqx-headers>=4.5
- makedepends = linux-lqx-headers<4.6
- depends = linux-lqx>=4.5
- depends = linux-lqx<4.6
+ makedepends = linux-lqx-headers>=4.6
+ makedepends = linux-lqx-headers<4.7
+ depends = linux-lqx>=4.6
+ depends = linux-lqx<4.7
depends = nvidia-340xx-libgl
depends = nvidia-340xx-utils=340.96
conflicts = nvidia-lqx
conflicts = nvidia-304xx-lqx
options = !strip
+ source = linux-4.6.patch
+ md5sums = 1f2baa65fd351ae7a2fc3dfd71ffcbfe
source_i686 = ftp://download.nvidia.com/XFree86/Linux-x86/340.96/NVIDIA-Linux-x86-340.96.run
md5sums_i686 = cb64b165b638671bcdc75bcf297b8d90
source_x86_64 = ftp://download.nvidia.com/XFree86/Linux-x86_64/340.96/NVIDIA-Linux-x86_64-340.96-no-compat32.run
diff --git a/PKGBUILD b/PKGBUILD
index af35770d86f4..9c39a26865a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: Piotr Gorski <lucjan.lucjanov@gmail.com> PGP-Key: 78695CFD
-# Contributor: shivik <> PGP-Key: 761E4.5C
+# Contributor: shivik <> PGP-Key: 761E4.6C
# Contributor : Thomas Baechler <thomas@archlinux.org>
pkgname=nvidia-340xx-lqx
pkgver=340.96
-_extramodules=extramodules-4.5-lqx
+_extramodules=extramodules-4.6-lqx
pkgrel=3
pkgdesc="NVIDIA drivers for linux-lqx, 340xx legacy branch"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-lqx>=4.5' 'linux-lqx<4.6' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
-makedepends=('linux-lqx-headers>=4.5' 'linux-lqx-headers<4.6')
+depends=('linux-lqx>=4.6' 'linux-lqx<4.7' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
+makedepends=('linux-lqx-headers>=4.6' 'linux-lqx-headers<4.7')
conflicts=('nvidia-lqx' 'nvidia-304xx-lqx')
license=('custom')
install=${pkgname}.install
options=(!strip)
-source_i686=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
-source_x86_64=("ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+source=('linux-4.6.patch')
+source_i686+=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+source_x86_64+=("ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+md5sums=('1f2baa65fd351ae7a2fc3dfd71ffcbfe')
md5sums_i686=('cb64b165b638671bcdc75bcf297b8d90')
md5sums_x86_64=('7bdbcee13bade63227933d9217571882')
@@ -26,6 +28,8 @@ md5sums_x86_64=('7bdbcee13bade63227933d9217571882')
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
+ # patches here
+ patch -p1 --no-backup-if-mismatch -i ../linux-4.6.patch
}
build() {
diff --git a/linux-4.6.patch b/linux-4.6.patch
new file mode 100644
index 000000000000..0495ce1cdb3e
--- /dev/null
+++ b/linux-4.6.patch
@@ -0,0 +1,150 @@
+--- /dev/null
++++ b/kernel/nv-mm.h
+@@ -0,0 +1,55 @@
++/*******************************************************************************
++ Copyright (c) 2016 NVIDIA Corporation
++
++ Permission is hereby granted, free of charge, to any person obtaining a copy
++ of this software and associated documentation files (the "Software"), to
++ deal in the Software without restriction, including without limitation the
++ rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
++ sell copies of the Software, and to permit persons to whom the Software is
++ furnished to do so, subject to the following conditions:
++
++ The above copyright notice and this permission notice shall be
++ included in all copies or substantial portions of the Software.
++
++ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
++ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
++ DEALINGS IN THE SOFTWARE.
++
++*******************************************************************************/
++#ifndef __NV_MM_H__
++#define __NV_MM_H__
++
++/* get_user_pages_remote() was added by:
++ * 2016 Feb 12: 1e9877902dc7e11d2be038371c6fbf2dfcd469d7
++ *
++ * The very next commit (cde70140fed8429acf7a14e2e2cbd3e329036653)
++ * deprecated the 8-argument version of get_user_pages for the
++ * non-remote case (calling get_user_pages with current and current->mm).
++ *
++ * The guidelines are: call NV_GET_USER_PAGES_REMOTE if you need the 8-argument
++ * version that uses something other than current and current->mm. Use
++ * NV_GET_USER_PAGES if you are refering to current and current->mm.
++ *
++* Note that get_user_pages_remote() requires the caller to hold a reference on
++* the task_struct (if non-NULL) and the mm_struct. This will always be true
++* when using current and current->mm. If the kernel passes the driver a vma
++* via driver callback, the kernel holds a reference on vma->vm_mm over that
++* callback.
++ */
++
++#if defined(NV_GET_USER_PAGES_REMOTE_PRESENT)
++ #define NV_GET_USER_PAGES get_user_pages
++ #define NV_GET_USER_PAGES_REMOTE get_user_pages_remote
++#else
++ #define NV_GET_USER_PAGES(start, nr_pages, write, force, pages, vmas) \
++ get_user_pages(current, current->mm, start, nr_pages, write, force, pages, vmas)
++
++ #define NV_GET_USER_PAGES_REMOTE get_user_pages
++#endif
++
++
++#endif // __NV_MM_H__
+--- a/kernel/os-mlock.c
++++ b/kernel/os-mlock.c
+@@ -13,6 +13,7 @@
+
+ #include "os-interface.h"
+ #include "nv-linux.h"
++#include "nv-mm.h"
+
+ RM_STATUS NV_API_CALL os_lock_user_pages(
+ void *address,
+@@ -45,7 +46,7 @@ RM_STATUS NV_API_CALL os_lock_user_pages(
+ }
+
+ down_read(&mm->mmap_sem);
+- ret = get_user_pages(current, mm, (unsigned long)address,
++ ret = NV_GET_USER_PAGES((unsigned long)address,
+ page_count, write, force, user_pages, NULL);
+ up_read(&mm->mmap_sem);
+ pinned = ret;
+@@ -59,7 +59,7 @@ RM_STATUS NV_API_CALL os_lock_user_pages(
+ else if (pinned < page_count)
+ {
+ for (i = 0; i < pinned; i++)
+- page_cache_release(user_pages[i]);
++ put_page(user_pages[i]);
+ os_free_mem(user_pages);
+ return RM_ERR_INVALID_ADDRESS;
+ }
+@@ -86,7 +86,7 @@ RM_STATUS NV_API_CALL os_unlock_user_pages(
+ {
+ if (write)
+ set_page_dirty_lock(user_pages[i]);
+- page_cache_release(user_pages[i]);
++ put_page(user_pages[i]);
+ }
+
+ os_free_mem(user_pages);
+diff --git a/kernel/conftest.sh.orig b/kernel/conftest.sh
+index d01488b..308ea8a 100755
+--- a/kernel/conftest.sh
++++ b/kernel/conftest.sh
+@@ -1669,6 +1669,23 @@ compile_test() {
+
+ compile_check_conftest "$CODE" "NV_NODE_END_PFN_PRESENT" "" "functions"
+ ;;
++
++ get_user_pages_remote)
++ #
++ # Determine if the function get_user_pages_remote() is
++ # present.
++ #
++ # get_user_pages_remote() was added by:
++ # 2016 Feb 12: 1e9877902dc7e11d2be038371c6fbf2dfcd469d7
++ #
++ CODE="
++ #include <linux/mm.h>
++ int conftest_get_user_pages_remote(void) {
++ get_user_pages_remote();
++ }"
++
++ compile_check_conftest "$CODE" "NV_GET_USER_PAGES_REMOTE_PRESENT" "" "functions"
++ ;;
+ esac
+ }
+
+diff --git a/kernel/Makefile.orig b/kernel/Makefile
+index 438d487..c52a36c 100644
+--- a/kernel/Makefile
++++ b/kernel/Makefile
+@@ -139,7 +139,8 @@ COMPILE_TESTS = \
+ drm_pci_set_busid \
+ write_cr4 \
+ for_each_online_node \
+- node_end_pfn
++ node_end_pfn \
++ get_user_pages_remote
+
+ #
+ # CFLAGS dependent on the type of builds (e.g. single/muliple module, debug)
+diff --git a/kernel/uvm/nvidia_uvm_lite.c.orig b/kernel/uvm/nvidia_uvm_lite.c
+index 442a0a8..695f092 100644
+--- a/kernel/uvm/nvidia_uvm_lite.c
++++ b/kernel/uvm/nvidia_uvm_lite.c
+@@ -785,7 +785,7 @@ int _fault_common(struct vm_area_struct *vma, unsigned long vaddr,
+ // a reference so that the fault handling logic is correct:
+ //
+ get_page(pTracking->uvmPage);
+- retValue = VM_FAULT_MINOR;
++ retValue = 0;
+ }
+
+ pRecord->isMapped = NV_TRUE;
diff --git a/nvidia-340xx-lqx.install b/nvidia-340xx-lqx.install
index 7011d0bb8f68..9c0f465912d2 100644
--- a/nvidia-340xx-lqx.install
+++ b/nvidia-340xx-lqx.install
@@ -1,5 +1,5 @@
post_install() {
- EXTRAMODULES='extramodules-4.5-lqx'
+ EXTRAMODULES='extramodules-4.6-lqx'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
echo 'In order to use nvidia module, reboot the system.'
}