summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandor Nagy2016-07-07 12:27:50 +0200
committerSandor Nagy2016-07-07 12:27:50 +0200
commit1f339c201cb06c26b954cd7f38a54088de838669 (patch)
treef669ea515ea46eecc98268267222d818d8f7b456
parent841179470be9de25ce531409873d4099040a93e9 (diff)
downloadaur-1f339c201cb06c26b954cd7f38a54088de838669.tar.gz
Update for kernel 4.6.x
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--linux-4.6.patch150
-rw-r--r--nvidia-340xx-rt.install6
4 files changed, 171 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccc3790a4f75..d436bf362a15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 3 19:57:30 UTC 2016
+# Thu Jul 7 10:24:21 UTC 2016
pkgbase = nvidia-340xx-rt
pkgdesc = NVIDIA drivers for linux-rt, 340xx legacy branch
pkgver = 340.96
- pkgrel = 2
+ pkgrel = 3
url = http://www.nvidia.com/
install = nvidia-340xx-rt.install
arch = i686
@@ -12,18 +12,18 @@ pkgbase = nvidia-340xx-rt
makedepends = nvidia-340xx-libgl=340.96
makedepends = nvidia-340xx-utils=340.96
makedepends = linux-rt
- makedepends = linux-rt-headers>=4.4
- makedepends = linux-rt-headers<4.5
- depends = linux-rt>=4.4
- depends = linux-rt<4.5
+ makedepends = linux-rt-headers>=4.6
+ makedepends = linux-rt-headers<4.7
+ depends = linux-rt>=4.6
+ depends = linux-rt<4.7
depends = libgl
depends = nvidia-340xx-utils=340.96
conflicts = nvidia-rt
conflicts = nvidia-last-rt
conflicts = nvidia-rt-lts
options = !strip
- source = nv-drm.patch
- md5sums = 79671a27131da619a33eb02ed0c2c031
+ source = linux-4.6.patch
+ md5sums = 1f2baa65fd351ae7a2fc3dfd71ffcbfe
source_i686 = http://us.download.nvidia.com/XFree86/Linux-x86/340.96/NVIDIA-Linux-x86-340.96.run
md5sums_i686 = cb64b165b638671bcdc75bcf297b8d90
source_x86_64 = http://us.download.nvidia.com/XFree86/Linux-x86_64/340.96/NVIDIA-Linux-x86_64-340.96-no-compat32.run
diff --git a/PKGBUILD b/PKGBUILD
index 6f6750410ef3..6ee70450d4bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,33 +7,33 @@
pkgname=nvidia-340xx-rt
pkgver=340.96
-_extramodules=extramodules-4.4-rt
-pkgrel=2
+_extramodules=extramodules-4.6-rt
+pkgrel=3
pkgdesc="NVIDIA drivers for linux-rt, 340xx legacy branch"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-rt>=4.4' 'linux-rt<4.5' 'libgl' "nvidia-340xx-utils=${pkgver}")
-makedepends=("nvidia-340xx-libgl=${pkgver}" "nvidia-340xx-utils=${pkgver}" 'linux-rt' 'linux-rt-headers>=4.4' 'linux-rt-headers<4.5')
+depends=('linux-rt>=4.6' 'linux-rt<4.7' 'libgl' "nvidia-340xx-utils=${pkgver}")
+makedepends=("nvidia-340xx-libgl=${pkgver}" "nvidia-340xx-utils=${pkgver}" 'linux-rt' 'linux-rt-headers>=4.6' 'linux-rt-headers<4.7')
conflicts=('nvidia-rt' 'nvidia-last-rt' 'nvidia-rt-lts')
license=('custom')
install=${pkgname}.install
options=(!strip)
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-source=(nv-drm.patch)
+source=('linux-4.6.patch')
+md5sums=('1f2baa65fd351ae7a2fc3dfd71ffcbfe')
md5sums_i686=('cb64b165b638671bcdc75bcf297b8d90')
md5sums_x86_64=('7bdbcee13bade63227933d9217571882')
-md5sums=('79671a27131da619a33eb02ed0c2c031')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
prepare() {
- rm -Rf ${srcdir}/${_pkg}
+ rm -Rf "${srcdir}/${_pkg}"
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
- patch -Np0 -i ../nv-drm.patch
+ patch -p1 --no-backup-if-mismatch -i ../linux-4.6.patch
}
build() {
@@ -50,8 +50,8 @@ package() {
install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
"${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
- "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
- gzip -9 "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
+ "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
+ gzip "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
install -d -m755 "${pkgdir}/etc/modprobe.d"
echo "blacklist nouveau" >> "${pkgdir}/etc/modprobe.d/${pkgname}.conf"
sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" "${startdir}/${pkgname}.install"
diff --git a/linux-4.6.patch b/linux-4.6.patch
new file mode 100644
index 000000000000..0495ce1cdb3e
--- /dev/null
+++ b/linux-4.6.patch
@@ -0,0 +1,150 @@
+--- /dev/null
++++ b/kernel/nv-mm.h
+@@ -0,0 +1,55 @@
++/*******************************************************************************
++ Copyright (c) 2016 NVIDIA Corporation
++
++ Permission is hereby granted, free of charge, to any person obtaining a copy
++ of this software and associated documentation files (the "Software"), to
++ deal in the Software without restriction, including without limitation the
++ rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
++ sell copies of the Software, and to permit persons to whom the Software is
++ furnished to do so, subject to the following conditions:
++
++ The above copyright notice and this permission notice shall be
++ included in all copies or substantial portions of the Software.
++
++ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
++ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
++ DEALINGS IN THE SOFTWARE.
++
++*******************************************************************************/
++#ifndef __NV_MM_H__
++#define __NV_MM_H__
++
++/* get_user_pages_remote() was added by:
++ * 2016 Feb 12: 1e9877902dc7e11d2be038371c6fbf2dfcd469d7
++ *
++ * The very next commit (cde70140fed8429acf7a14e2e2cbd3e329036653)
++ * deprecated the 8-argument version of get_user_pages for the
++ * non-remote case (calling get_user_pages with current and current->mm).
++ *
++ * The guidelines are: call NV_GET_USER_PAGES_REMOTE if you need the 8-argument
++ * version that uses something other than current and current->mm. Use
++ * NV_GET_USER_PAGES if you are refering to current and current->mm.
++ *
++* Note that get_user_pages_remote() requires the caller to hold a reference on
++* the task_struct (if non-NULL) and the mm_struct. This will always be true
++* when using current and current->mm. If the kernel passes the driver a vma
++* via driver callback, the kernel holds a reference on vma->vm_mm over that
++* callback.
++ */
++
++#if defined(NV_GET_USER_PAGES_REMOTE_PRESENT)
++ #define NV_GET_USER_PAGES get_user_pages
++ #define NV_GET_USER_PAGES_REMOTE get_user_pages_remote
++#else
++ #define NV_GET_USER_PAGES(start, nr_pages, write, force, pages, vmas) \
++ get_user_pages(current, current->mm, start, nr_pages, write, force, pages, vmas)
++
++ #define NV_GET_USER_PAGES_REMOTE get_user_pages
++#endif
++
++
++#endif // __NV_MM_H__
+--- a/kernel/os-mlock.c
++++ b/kernel/os-mlock.c
+@@ -13,6 +13,7 @@
+
+ #include "os-interface.h"
+ #include "nv-linux.h"
++#include "nv-mm.h"
+
+ RM_STATUS NV_API_CALL os_lock_user_pages(
+ void *address,
+@@ -45,7 +46,7 @@ RM_STATUS NV_API_CALL os_lock_user_pages(
+ }
+
+ down_read(&mm->mmap_sem);
+- ret = get_user_pages(current, mm, (unsigned long)address,
++ ret = NV_GET_USER_PAGES((unsigned long)address,
+ page_count, write, force, user_pages, NULL);
+ up_read(&mm->mmap_sem);
+ pinned = ret;
+@@ -59,7 +59,7 @@ RM_STATUS NV_API_CALL os_lock_user_pages(
+ else if (pinned < page_count)
+ {
+ for (i = 0; i < pinned; i++)
+- page_cache_release(user_pages[i]);
++ put_page(user_pages[i]);
+ os_free_mem(user_pages);
+ return RM_ERR_INVALID_ADDRESS;
+ }
+@@ -86,7 +86,7 @@ RM_STATUS NV_API_CALL os_unlock_user_pages(
+ {
+ if (write)
+ set_page_dirty_lock(user_pages[i]);
+- page_cache_release(user_pages[i]);
++ put_page(user_pages[i]);
+ }
+
+ os_free_mem(user_pages);
+diff --git a/kernel/conftest.sh.orig b/kernel/conftest.sh
+index d01488b..308ea8a 100755
+--- a/kernel/conftest.sh
++++ b/kernel/conftest.sh
+@@ -1669,6 +1669,23 @@ compile_test() {
+
+ compile_check_conftest "$CODE" "NV_NODE_END_PFN_PRESENT" "" "functions"
+ ;;
++
++ get_user_pages_remote)
++ #
++ # Determine if the function get_user_pages_remote() is
++ # present.
++ #
++ # get_user_pages_remote() was added by:
++ # 2016 Feb 12: 1e9877902dc7e11d2be038371c6fbf2dfcd469d7
++ #
++ CODE="
++ #include <linux/mm.h>
++ int conftest_get_user_pages_remote(void) {
++ get_user_pages_remote();
++ }"
++
++ compile_check_conftest "$CODE" "NV_GET_USER_PAGES_REMOTE_PRESENT" "" "functions"
++ ;;
+ esac
+ }
+
+diff --git a/kernel/Makefile.orig b/kernel/Makefile
+index 438d487..c52a36c 100644
+--- a/kernel/Makefile
++++ b/kernel/Makefile
+@@ -139,7 +139,8 @@ COMPILE_TESTS = \
+ drm_pci_set_busid \
+ write_cr4 \
+ for_each_online_node \
+- node_end_pfn
++ node_end_pfn \
++ get_user_pages_remote
+
+ #
+ # CFLAGS dependent on the type of builds (e.g. single/muliple module, debug)
+diff --git a/kernel/uvm/nvidia_uvm_lite.c.orig b/kernel/uvm/nvidia_uvm_lite.c
+index 442a0a8..695f092 100644
+--- a/kernel/uvm/nvidia_uvm_lite.c
++++ b/kernel/uvm/nvidia_uvm_lite.c
+@@ -785,7 +785,7 @@ int _fault_common(struct vm_area_struct *vma, unsigned long vaddr,
+ // a reference so that the fault handling logic is correct:
+ //
+ get_page(pTracking->uvmPage);
+- retValue = VM_FAULT_MINOR;
++ retValue = 0;
+ }
+
+ pRecord->isMapped = NV_TRUE;
diff --git a/nvidia-340xx-rt.install b/nvidia-340xx-rt.install
index ddfbaf1cff64..70712cb687d5 100644
--- a/nvidia-340xx-rt.install
+++ b/nvidia-340xx-rt.install
@@ -1,11 +1,11 @@
post_install() {
- EXTRAMODULES='extramodules-4.4-rt'
+ EXTRAMODULES='extramodules-4.6-rt'
depmod $(cat /lib/modules/$EXTRAMODULES/version)
echo 'In order to use nvidia module, reboot the system.'
}
post_upgrade() {
- EXTRAMODULES='extramodules-4.4-rt'
+ EXTRAMODULES='extramodules-4.6-rt'
depmod $(cat /lib/modules/$EXTRAMODULES/version)
if [ "$(vercmp $2 310.19-2)" -lt 0 ]; then
echo 'If your card is from the 7xxx series or earlier, install nvidia-304xx'
@@ -13,6 +13,6 @@ post_upgrade() {
}
post_remove() {
- EXTRAMODULES='extramodules-4.4-rt'
+ EXTRAMODULES='extramodules-4.6-rt'
depmod $(cat /lib/modules/$EXTRAMODULES/version)
}