summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandor Nagy2015-09-28 19:54:06 +0200
committerSandor Nagy2015-09-28 20:11:40 +0200
commitdbeaf16f1e945cbb8be0c180d015051628693f43 (patch)
tree0d7e31c72c0292aac5b68717a8b0ff0c78c58e05
parent8585ff298abff69f9b030790469f82d1d41f3026 (diff)
downloadaur-dbeaf16f1e945cbb8be0c180d015051628693f43.tar.gz
New upstream
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
-rw-r--r--nvidia-4.0.patch28
3 files changed, 18 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f109bb46e0e..e3809511abdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,31 @@
pkgbase = nvidia-340xx-rt
pkgdesc = NVIDIA drivers for linux-rt, 340xx legacy branch
- pkgver = 340.76
- pkgrel = 6
+ pkgver = 340.93
+ pkgrel = 1
url = http://www.nvidia.com/
install = nvidia-340xx-rt.install
arch = i686
arch = x86_64
license = custom
+ makedepends = nvidia-340xx-libgl=340.93
+ makedepends = nvidia-340xx-utils=340.93
makedepends = linux-rt
makedepends = linux-rt-headers>=4.1
makedepends = linux-rt-headers<4.2
depends = linux-rt>=4.1
depends = linux-rt<4.2
- depends = nvidia-340xx-utils=340.76
+ depends = libgl
+ depends = nvidia-340xx-utils=340.93
conflicts = nvidia-rt
conflicts = nvidia-last-rt
conflicts = nvidia-rt-lts
options = !strip
source = nv-drm.patch
- source = nvidia-4.0.patch
md5sums = 79671a27131da619a33eb02ed0c2c031
- md5sums = f42bdf589f52d4e6c38baa5bef15eef8
- source_i686 = http://us.download.nvidia.com/XFree86/Linux-x86/340.76/NVIDIA-Linux-x86-340.76.run
- md5sums_i686 = 8064c0a0998c3e7ee3c98ac1832b8194
- source_x86_64 = http://us.download.nvidia.com/XFree86/Linux-x86_64/340.76/NVIDIA-Linux-x86_64-340.76-no-compat32.run
- md5sums_x86_64 = 440df290e213280d6e20d4d4be6f8b4c
+ source_i686 = http://us.download.nvidia.com/XFree86/Linux-x86/340.93/NVIDIA-Linux-x86-340.93.run
+ md5sums_i686 = 4a7edf6838a80c77a57fb6f6ec7f0437
+ source_x86_64 = http://us.download.nvidia.com/XFree86/Linux-x86_64/340.93/NVIDIA-Linux-x86_64-340.93-no-compat32.run
+ md5sums_x86_64 = cb80e3f1cb6f2fb6e6eab35fad0884e4
pkgname = nvidia-340xx-rt
diff --git a/PKGBUILD b/PKGBUILD
index 0e84912f8d9f..349153123328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,26 +6,24 @@
# Contributor: 325.15 - patch : Ninez
pkgname=nvidia-340xx-rt
-pkgver=340.76
+pkgver=340.93
_extramodules=extramodules-4.1-rt
-pkgrel=6
+pkgrel=1
pkgdesc="NVIDIA drivers for linux-rt, 340xx legacy branch"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-rt>=4.1' 'linux-rt<4.2' "nvidia-340xx-utils=${pkgver}")
-makedepends=('linux-rt' 'linux-rt-headers>=4.1' 'linux-rt-headers<4.2')
+depends=('linux-rt>=4.1' 'linux-rt<4.2' 'libgl' "nvidia-340xx-utils=${pkgver}")
+makedepends=("nvidia-340xx-libgl=${pkgver}" "nvidia-340xx-utils=${pkgver}" 'linux-rt' 'linux-rt-headers>=4.1' 'linux-rt-headers<4.2')
conflicts=('nvidia-rt' 'nvidia-last-rt' 'nvidia-rt-lts')
license=('custom')
install=${pkgname}.install
options=(!strip)
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-source=(nv-drm.patch
- nvidia-4.0.patch)
-md5sums_i686=('8064c0a0998c3e7ee3c98ac1832b8194')
-md5sums_x86_64=('440df290e213280d6e20d4d4be6f8b4c')
-md5sums=('79671a27131da619a33eb02ed0c2c031'
- 'f42bdf589f52d4e6c38baa5bef15eef8')
+source=(nv-drm.patch)
+md5sums_i686=('4a7edf6838a80c77a57fb6f6ec7f0437')
+md5sums_x86_64=('cb80e3f1cb6f2fb6e6eab35fad0884e4')
+md5sums=('79671a27131da619a33eb02ed0c2c031')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
@@ -36,7 +34,6 @@ prepare() {
cd "${_pkg}"
patch -Np0 -i ../nv-drm.patch
- patch -Np0 -i ../nvidia-4.0.patch
}
build() {
diff --git a/nvidia-4.0.patch b/nvidia-4.0.patch
deleted file mode 100644
index 905ebeaf3fde..000000000000
--- a/nvidia-4.0.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- kernel/nv-pat.c~ 2015-02-22 20:39:43.889075396 -0800
-+++ kernel/nv-pat.c 2015-02-22 20:29:33.519735577 -0800
-@@ -35,8 +35,13 @@
- unsigned long cr0 = read_cr0();
- write_cr0(((cr0 & (0xdfffffff)) | 0x40000000));
- wbinvd();
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,0,0)
-+ *cr4 = __read_cr4();
-+ if (*cr4 & 0x80) __write_cr4(*cr4 & ~0x80);
-+#else
- *cr4 = read_cr4();
- if (*cr4 & 0x80) write_cr4(*cr4 & ~0x80);
-+#endif
- __flush_tlb();
- }
-
-@@ -46,7 +46,11 @@
- wbinvd();
- __flush_tlb();
- write_cr0((cr0 & 0x9fffffff));
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,0,0)
-+ if (cr4 & 0x80) __write_cr4(cr4);
-+#else
- if (cr4 & 0x80) write_cr4(cr4);
-+#endif
- }
-
- static int nv_determine_pat_mode(void)