summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2016-01-20 01:53:13 +0100
committerBalló György2016-01-20 01:53:13 +0100
commit25672fd5b83eff1b827b314711c138b6a250b2a7 (patch)
tree0de9c1d02994c2504116872f6032b0fb55458998
parent2b02f7b0ffedbb6d716d5710fe9284f639fbeb43 (diff)
downloadaur-25672fd5b83eff1b827b314711c138b6a250b2a7.tar.gz
upgpkg: nvidia-96xx-dkms 96.43.23-5
Update to linux 4.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--linux-4.3.patch13
3 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0cb5f41c5e0..56b4794079b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Jan 20 00:53:13 UTC 2016
pkgbase = nvidia-96xx-dkms
pkgdesc = NVIDIA kernel module sources (DKMS), 96xx branch
pkgver = 96.43.23
- pkgrel = 4
+ pkgrel = 5
url = http://www.nvidia.com/
install = nvidia-dkms.install
arch = i686
@@ -21,12 +23,14 @@ pkgbase = nvidia-96xx-dkms
source = linux-3.17.patch
source = linux-3.19.patch
source = linux-4.0.patch
+ source = linux-4.3.patch
source = dkms.conf
md5sums = 944ed806c8d0f9174d5e9e16ae065bf6
md5sums = f2e605724a13ee01bf290df3bf9a3a93
md5sums = a613531fc6a5610e8e07b1dded071901
md5sums = ab3e06a699bfd0a91ab77a88e112ad44
md5sums = 89072d9c1b37867f01dd7a41521c0ed1
+ md5sums = 75273776a44fdb0fa8caa9479ce00094
md5sums = d28e74675462b215f080960c130c43fc
pkgname = nvidia-96xx-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 6ab1fc4ab243..2597e27741c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=nvidia-96xx-dkms
pkgver=96.43.23
-pkgrel=4
+pkgrel=5
pkgdesc="NVIDIA kernel module sources (DKMS), 96xx branch"
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && _arch=x86
@@ -25,6 +25,7 @@ source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.
linux-3.17.patch
linux-3.19.patch
linux-4.0.patch
+ linux-4.3.patch
dkms.conf)
options=(!strip)
[ "$CARCH" = "i686" ] && md5sums=('ca0bc6ae3b37cb259f3a906b4dc4670b')
@@ -34,6 +35,7 @@ md5sums+=('944ed806c8d0f9174d5e9e16ae065bf6'
'a613531fc6a5610e8e07b1dded071901'
'ab3e06a699bfd0a91ab77a88e112ad44'
'89072d9c1b37867f01dd7a41521c0ed1'
+ '75273776a44fdb0fa8caa9479ce00094'
'd28e74675462b215f080960c130c43fc')
prepare() {
@@ -49,6 +51,7 @@ prepare() {
patch -p1 -i "$srcdir/linux-3.17.patch"
patch -p1 -i "$srcdir/linux-3.19.patch"
patch -p1 -i "$srcdir/linux-4.0.patch"
+ patch -p1 -i "$srcdir/linux-4.3.patch"
rm *.orig
}
diff --git a/linux-4.3.patch b/linux-4.3.patch
new file mode 100644
index 000000000000..9ce8211fe2d5
--- /dev/null
+++ b/linux-4.3.patch
@@ -0,0 +1,13 @@
+diff -Naur nv.orig/nv.c nv/nv.c
+--- nv.orig/nv.c 2016-01-20 01:34:02.096524000 +0100
++++ nv/nv.c 2016-01-20 01:36:47.610695762 +0100
+@@ -574,7 +574,8 @@
+ void *v
+ )
+ {
+- return seq_puts(s, s->private);
++ seq_puts(s, s->private);
++ return 0;
+ }
+
+ NV_DEFINE_PROCFS_SINGLE_FILE(text_file);