summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-09-21 03:02:32 +0000
committerDaniel Bermond2018-09-21 03:02:32 +0000
commit8462e8e0326fc134ce753f03d1261cddb960cfe1 (patch)
treec5939c565b9447fa487ada1cc75614bad0cf6289
parent147b0ef223cb9b64c0392a83f4658cf8a148b366 (diff)
downloadaur-8462e8e0326fc134ce753f03d1261cddb960cfe1.tar.gz
Updated to version 410.57
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--linux-4.16.patch33
3 files changed, 53 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c03592cd393..e2d277dbad25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nvidia-beta
pkgdesc = NVIDIA driver for Arch's official 'linux' package (beta version)
- pkgver = 396.54
+ pkgver = 410.57
pkgrel = 1
url = http://www.nvidia.com/
install = nvidia-beta.install
@@ -8,15 +8,17 @@ pkgbase = nvidia-beta
license = custom:NVIDIA
makedepends = linux-headers
depends = linux
- depends = nvidia-utils-beta>=396.54
+ depends = nvidia-utils-beta>=410.57
depends = libgl
- provides = nvidia=396.54
+ provides = nvidia=410.57
conflicts = nvidia-96xx
conflicts = nvidia-173xx
conflicts = nvidia
options = !strip
- source = http://us.download.nvidia.com/XFree86/Linux-x86_64/396.54/NVIDIA-Linux-x86_64-396.54-no-compat32.run
- md5sums = 710acf72a2d8dde844dd2638e0782819
+ source = http://us.download.nvidia.com/XFree86/Linux-x86_64/410.57/NVIDIA-Linux-x86_64-410.57-no-compat32.run
+ source = linux-4.16.patch
+ sha256sums = 1ad40d83ec712843c1b5593949abefc9093399fb26a418ae9a571fbd1d9b228e
+ sha256sums = 622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385
pkgname = nvidia-beta
diff --git a/PKGBUILD b/PKGBUILD
index 33ddfb280b79..412142704821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,12 @@
-# Maintainer: Det <nimetonmaili g-mail>
-# Contributors: Ng Oon-Ee, Dan Vratil
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Det <nimetonmaili g-mail>
+# Contributor: Ng Oon-Ee
+# Contributor: Dan
+# Contributor: Vratil
# Based on [extra]'s nvidia: https://www.archlinux.org/packages/extra/x86_64/nvidia/
pkgname=nvidia-beta
-pkgver=396.54
+pkgver=410.57
pkgrel=1
pkgdesc="NVIDIA driver for Arch's official 'linux' package (beta version)"
arch=('x86_64')
@@ -17,19 +20,21 @@ options=('!strip')
install=$pkgname.install
_pkg="NVIDIA-Linux-x86_64-$pkgver-no-compat32"
source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/$pkgver/$_pkg.run")
-md5sums=('710acf72a2d8dde844dd2638e0782819')
+sha256sums=('1ad40d83ec712843c1b5593949abefc9093399fb26a418ae9a571fbd1d9b228e')
_extramodules=extramodules-ARCH
-# Patch
-#source+=('linux-4.11.patch')
-#md5sums+=('cc8941b6898d9daa0fb67371f57a56b6')
+# Patches
+## restore phys_to_dma support
+## https://bugs.archlinux.org/task/58074
+source+=('linux-4.16.patch')
+sha256sums+=('622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385')
# Auto-add *.patch files from $startdir to source=()
for _patch in $(find "$startdir" -maxdepth 1 -name '*.patch' -printf "%f\n"); do
# Don't duplicate already listed ones
if [[ ! " ${source[@]} " =~ " $_patch " ]]; then # https://stackoverflow.com/a/15394738/1821548
source+=("$_patch")
- md5sums+=('SKIP')
+ sha256sums+=('SKIP')
fi
done
diff --git a/linux-4.16.patch b/linux-4.16.patch
new file mode 100644
index 000000000000..67172815ff69
--- /dev/null
+++ b/linux-4.16.patch
@@ -0,0 +1,33 @@
+diff --git a/kernel/common/inc/nv-linux.h b/kernel/common/inc/nv-linux.h
+index 10fc418..22ef968 100644
+--- a/kernel/common/inc/nv-linux.h
++++ b/kernel/common/inc/nv-linux.h
+@@ -175,7 +175,11 @@ static inline uid_t __kuid_val(kuid_t uid)
+
+ #if defined(NV_VM_INSERT_PAGE_PRESENT)
+ #include <linux/pagemap.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
+ #include <linux/dma-mapping.h>
++#else
++#include <linux/dma-direct.h>
++#endif
+ #endif
+
+ #if defined(CONFIG_SWIOTLB) && defined(NVCPU_AARCH64)
+diff --git a/kernel/conftest.sh b/kernel/conftest.sh
+index b23dbb4..42dc576 100755
+--- a/kernel/conftest.sh
++++ b/kernel/conftest.sh
+@@ -1906,7 +1906,12 @@ compile_test() {
+ # Determine if the phys_to_dma function is present.
+ #
+ CODE="
++ #include <linux/version.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
+ #include <linux/dma-mapping.h>
++#else
++ #include <linux/dma-direct.h>
++#endif
+ void conftest_phys_to_dma(void) {
+ phys_to_dma();
+ }"