summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-04-24 22:20:18 +0000
committerDaniel Bermond2019-04-24 22:20:18 +0000
commit8cbdffe05e901a2fb100f47d1c4d7d6d59f48c38 (patch)
tree8231eb965e7d26375a9c0159d04317a936822c79
parent4e724f5352ec7d4ecea622abede848a1bceadaf3 (diff)
downloadaur-8cbdffe05e901a2fb100f47d1c4d7d6d59f48c38.tar.gz
Updated to version 430.09
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
-rw-r--r--linux-4.16.patch33
3 files changed, 14 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf4d1951fdaf..9bc8d98dbb0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = nvidia-beta-all
pkgdesc = NVIDIA drivers for all kernels on the system (beta)
- pkgver = 418.56
+ pkgver = 430.09
pkgrel = 1
url = https://www.nvidia.com/
arch = x86_64
license = custom:NVIDIA
makedepends = linux-headers
- depends = nvidia-utils-beta>=418.56
+ depends = nvidia-utils-beta>=430.09
depends = libgl
- provides = nvidia=418.56
- provides = nvidia-beta=418.56
+ provides = nvidia=430.09
+ provides = nvidia-beta=430.09
conflicts = nvidia
options = !strip
- source = https://us.download.nvidia.com/XFree86/Linux-x86_64/418.56/NVIDIA-Linux-x86_64-418.56-no-compat32.run
- source = linux-4.16.patch
- sha256sums = 5e5cfcc6a392ceee156d3a55fc1c1cdebd5831b371163c6028fe409cefbf9d43
- sha256sums = 622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385
+ source = https://us.download.nvidia.com/XFree86/Linux-x86_64/430.09/NVIDIA-Linux-x86_64-430.09-no-compat32.run
+ sha256sums = 247e127fcf1f1902193104f22ca69e1974f834b3c4502a0eba42312b8d6c88b9
pkgname = nvidia-beta-all
diff --git a/PKGBUILD b/PKGBUILD
index 4d151e38ea13..9d717828865d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Based on nvidia-beta: https://aur.archlinux.org/packages/nvidia-beta/
pkgname=nvidia-beta-all
-pkgver=418.56
+pkgver=430.09
pkgrel=1
pkgdesc='NVIDIA drivers for all kernels on the system (beta)'
arch=('x86_64')
@@ -16,10 +16,8 @@ provides=("nvidia=${pkgver}" "nvidia-beta=${pkgver}")
conflicts=('nvidia')
options=('!strip')
_pkg="NVIDIA-Linux-${CARCH}-${pkgver}-no-compat32"
-source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run"
- 'linux-4.16.patch')
-sha256sums=('5e5cfcc6a392ceee156d3a55fc1c1cdebd5831b371163c6028fe409cefbf9d43'
- '622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385')
+source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run")
+sha256sums=('247e127fcf1f1902193104f22ca69e1974f834b3c4502a0eba42312b8d6c88b9')
prepare() {
local _kernel
@@ -36,14 +34,13 @@ prepare() {
do
cp -a kernel "kernel-${_kernel}"
- printf '%s\n' " -> Applying patch(es) for kernel ${_kernel}..."
- cd "kernel-${_kernel}"
+ #printf '%s\n' " -> Applying patch(es) for kernel ${_kernel}..."
+ #cd "kernel-${_kernel}"
- # restore phys_to_dma support
- # https://bugs.archlinux.org/task/58074
- patch -Np2 -i "${srcdir}/linux-4.16.patch"
+ # apply patches(es) here:
+ #patch -Np2 -i "${srcdir}/<patch>"
- cd ..
+ #cd ..
done
}
diff --git a/linux-4.16.patch b/linux-4.16.patch
deleted file mode 100644
index 67172815ff69..000000000000
--- a/linux-4.16.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/kernel/common/inc/nv-linux.h b/kernel/common/inc/nv-linux.h
-index 10fc418..22ef968 100644
---- a/kernel/common/inc/nv-linux.h
-+++ b/kernel/common/inc/nv-linux.h
-@@ -175,7 +175,11 @@ static inline uid_t __kuid_val(kuid_t uid)
-
- #if defined(NV_VM_INSERT_PAGE_PRESENT)
- #include <linux/pagemap.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
- #include <linux/dma-mapping.h>
-+#else
-+#include <linux/dma-direct.h>
-+#endif
- #endif
-
- #if defined(CONFIG_SWIOTLB) && defined(NVCPU_AARCH64)
-diff --git a/kernel/conftest.sh b/kernel/conftest.sh
-index b23dbb4..42dc576 100755
---- a/kernel/conftest.sh
-+++ b/kernel/conftest.sh
-@@ -1906,7 +1906,12 @@ compile_test() {
- # Determine if the phys_to_dma function is present.
- #
- CODE="
-+ #include <linux/version.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
- #include <linux/dma-mapping.h>
-+#else
-+ #include <linux/dma-direct.h>
-+#endif
- void conftest_phys_to_dma(void) {
- phys_to_dma();
- }"