summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-06-24 20:56:02 +0000
committerDaniel Bermond2020-06-24 20:56:02 +0000
commitb22314cfc4b2aba061872a1953f96e65ab9aab27 (patch)
tree7c428e4b2cd6b2b333739eb1e6b991545413cdb6
parentb1bbff233daca37ed8f5333afb9cf4b509763e5c (diff)
downloadaur-b22314cfc4b2aba061872a1953f96e65ab9aab27.tar.gz
Updated to version 450.51
-rw-r--r--.SRCINFO16
-rw-r--r--010-nvidia-kernel-5.7.patch8
-rw-r--r--PKGBUILD8
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7e8af3fc65a..2616ae377638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = nvidia-beta-all
pkgdesc = NVIDIA drivers for all kernels on the system (beta version)
- pkgver = 440.82
- pkgrel = 2
+ pkgver = 450.51
+ pkgrel = 1
url = https://www.nvidia.com/
arch = x86_64
license = custom
makedepends = linux
makedepends = linux-headers
- depends = nvidia-utils-beta>=440.82
+ depends = nvidia-utils-beta>=450.51
depends = libglvnd
- provides = nvidia=440.82
- provides = nvidia-beta=440.82
+ provides = nvidia=450.51
+ provides = nvidia-beta=450.51
conflicts = nvidia
options = !strip
- source = https://us.download.nvidia.com/XFree86/Linux-x86_64/440.82/NVIDIA-Linux-x86_64-440.82-no-compat32.run
+ source = https://us.download.nvidia.com/XFree86/Linux-x86_64/450.51/NVIDIA-Linux-x86_64-450.51-no-compat32.run
source = 010-nvidia-kernel-5.7.patch
- sha256sums = 89feda0c3e54c9c0d0528760bbb5cf4d8e57408fb3df2728653f3a1b73c110a9
- sha256sums = 58c735ff7a1ad4a5d6729246444de6bd2be1c4a9eec2e9b3adcc9ef2a3389d38
+ sha256sums = 7e08a97f68e9d4b8fbae9811926fdfbff216fa37252aa114425bc1aa85730d22
+ sha256sums = 37cf072fdaee3f9f0c5a8b4d5f2dac722c7b96720fc317bc2da947bde52fb946
pkgname = nvidia-beta-all
diff --git a/010-nvidia-kernel-5.7.patch b/010-nvidia-kernel-5.7.patch
index c0600228a52e..d7c58e10d7f0 100644
--- a/010-nvidia-kernel-5.7.patch
+++ b/010-nvidia-kernel-5.7.patch
@@ -1,6 +1,6 @@
--- a/kernel/conftest.sh
+++ b/kernel/conftest.sh
-@@ -143,6 +143,7 @@ test_headers() {
+@@ -144,6 +144,7 @@ test_headers() {
FILES="$FILES video/nv_internal.h"
FILES="$FILES asm/book3s/64/hash-64k.h"
FILES="$FILES asm/set_memory.h"
@@ -8,7 +8,7 @@
FILES="$FILES asm/prom.h"
FILES="$FILES asm/powernv.h"
FILES="$FILES asm/tlbflush.h"
-@@ -466,6 +467,9 @@ compile_test() {
+@@ -471,6 +472,9 @@ compile_test() {
# It does not exist on all architectures.
#
CODE="
@@ -16,5 +16,5 @@
+ #include <asm/pgtable.h>
+ #endif
#if defined(NV_ASM_SET_MEMORY_H_PRESENT)
- #include <asm/set_memory.h>
- #else
+ #if defined(NV_ASM_PGTABLE_TYPES_H_PRESENT)
+ #include <asm/pgtable_types.h>
diff --git a/PKGBUILD b/PKGBUILD
index 478b270c0f88..75ac8a25138d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Ng Oon-Ee
pkgname=nvidia-beta-all
-pkgver=440.82
-pkgrel=2
+pkgver=450.51
+pkgrel=1
pkgdesc='NVIDIA drivers for all kernels on the system (beta version)'
arch=('x86_64')
url='https://www.nvidia.com/'
@@ -17,8 +17,8 @@ options=('!strip')
_pkg="NVIDIA-Linux-${CARCH}-${pkgver}-no-compat32"
source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run"
'010-nvidia-kernel-5.7.patch')
-sha256sums=('89feda0c3e54c9c0d0528760bbb5cf4d8e57408fb3df2728653f3a1b73c110a9'
- '58c735ff7a1ad4a5d6729246444de6bd2be1c4a9eec2e9b3adcc9ef2a3389d38')
+sha256sums=('7e08a97f68e9d4b8fbae9811926fdfbff216fa37252aa114425bc1aa85730d22'
+ '37cf072fdaee3f9f0c5a8b4d5f2dac722c7b96720fc317bc2da947bde52fb946')
prepare() {
# extract the source file