summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2019-05-17 14:16:11 -0400
committergraysky2019-05-17 14:16:11 -0400
commit58b2cbd8fa933f8969651a6a381c7051b1e73d53 (patch)
tree30e51a79d7461eb8f49493232342723abbe801aa
parent683fb31525bfaa851734e4d9118f05aa91fd5e25 (diff)
downloadaur-58b2cbd8fa933f8969651a6a381c7051b1e73d53.tar.gz
Update to 430.14-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD15
-rw-r--r--fs62142.patch13
-rw-r--r--kernel-4.16.patch33
4 files changed, 30 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de66afa7d7c2..aae14ab4812b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
+# Generated by mksrcinfo v8
+# Fri May 17 18:16:11 UTC 2019
pkgbase = nvidia-ck
pkgdesc = NVIDIA drivers for linux-ck.
- pkgver = 418.74
- pkgrel = 4
+ pkgver = 430.14
+ pkgrel = 1
epoch = 2
url = http://www.nvidia.com/
arch = x86_64
license = custom
- makedepends = nvidia-utils=418.74
+ makedepends = nvidia-utils=430.14
makedepends = libglvnd
makedepends = linux-ck-headers
depends = linux-ck
depends = libgl
- depends = nvidia-utils=418.74
+ depends = nvidia-utils=430.14
conflicts = nvidia-340xx-ck
conflicts = nvidia-390xx-ck
options = !strip
- source = http://us.download.nvidia.com/XFree86/Linux-x86_64/418.74/NVIDIA-Linux-x86_64-418.74.run
- source = kernel-4.16.patch
- sha256sums = dc8736decb9627e18d71a5b3cb1273682d649208eca7dce0b589cd7faf20120f
- sha256sums = 622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385
+ source = http://us.download.nvidia.com/XFree86/Linux-x86_64/430.14/NVIDIA-Linux-x86_64-430.14.run
+ source = fs62142.patch
+ sha256sums = 00d46ffaf3e1e430081ddbd68b74cc361cd1328e8944224dfe69630dd8540f17
+ sha256sums = 24a3082688ee4d60d27f601d535b1e6ced7537b46cc83fc9bb6da0f76e07e017
pkgname = nvidia-ck
diff --git a/PKGBUILD b/PKGBUILD
index 4f72309af437..f204a7966488 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contrubutor: Thomas Baechler <thomas@archlinux.org>
pkgname=nvidia-ck
-pkgver=418.74
-pkgrel=4
+pkgver=430.14
+pkgrel=1
epoch=2
_extramodules=extramodules-ck
_pkgdesc="NVIDIA drivers for linux-ck."
@@ -20,17 +20,16 @@ license=('custom')
options=('!strip')
_pkg="NVIDIA-Linux-x86_64-${pkgver}"
source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/${_pkg}.run"
-kernel-4.16.patch)
-sha256sums=('dc8736decb9627e18d71a5b3cb1273682d649208eca7dce0b589cd7faf20120f'
- '622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385')
+ fs62142.patch)
+sha256sums=('00d46ffaf3e1e430081ddbd68b74cc361cd1328e8944224dfe69630dd8540f17'
+ '24a3082688ee4d60d27f601d535b1e6ced7537b46cc83fc9bb6da0f76e07e017')
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
- # Restore phys_to_dma support (still needed for 396.18)
- # https://bugs.archlinux.org/task/58074
- patch -Np1 -i ../kernel-4.16.patch
+ # Fix https://bugs.archlinux.org/task/62142
+ patch -Np1 -i ../fs62142.patch
}
build() {
diff --git a/fs62142.patch b/fs62142.patch
new file mode 100644
index 000000000000..04806bd8d154
--- /dev/null
+++ b/fs62142.patch
@@ -0,0 +1,13 @@
+diff --git a/kernel/nvidia/nv-dma.c b/kernel/nvidia/nv-dma.c
+index 73cdeed..e691014 100644
+--- a/kernel/nvidia/nv-dma.c
++++ b/kernel/nvidia/nv-dma.c
+@@ -606,7 +606,7 @@ static NvBool nv_dma_is_map_resource_implemented
+ #if defined(NV_DMA_MAP_RESOURCE_PRESENT)
+ const struct dma_map_ops *ops = get_dma_ops(&nvl->dev->dev);
+
+- return (ops->map_resource != NULL);
++ return (ops && ops->map_resource);
+ #else
+ return NV_FALSE;
+ #endif
diff --git a/kernel-4.16.patch b/kernel-4.16.patch
deleted file mode 100644
index 67172815ff69..000000000000
--- a/kernel-4.16.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/kernel/common/inc/nv-linux.h b/kernel/common/inc/nv-linux.h
-index 10fc418..22ef968 100644
---- a/kernel/common/inc/nv-linux.h
-+++ b/kernel/common/inc/nv-linux.h
-@@ -175,7 +175,11 @@ static inline uid_t __kuid_val(kuid_t uid)
-
- #if defined(NV_VM_INSERT_PAGE_PRESENT)
- #include <linux/pagemap.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
- #include <linux/dma-mapping.h>
-+#else
-+#include <linux/dma-direct.h>
-+#endif
- #endif
-
- #if defined(CONFIG_SWIOTLB) && defined(NVCPU_AARCH64)
-diff --git a/kernel/conftest.sh b/kernel/conftest.sh
-index b23dbb4..42dc576 100755
---- a/kernel/conftest.sh
-+++ b/kernel/conftest.sh
-@@ -1906,7 +1906,12 @@ compile_test() {
- # Determine if the phys_to_dma function is present.
- #
- CODE="
-+ #include <linux/version.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
- #include <linux/dma-mapping.h>
-+#else
-+ #include <linux/dma-direct.h>
-+#endif
- void conftest_phys_to_dma(void) {
- phys_to_dma();
- }"