summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCabopust2021-02-15 13:44:22 +0300
committerCabopust2021-02-15 13:44:22 +0300
commit9dae1c60464afc6eb7795e43d6b857ff225c14e1 (patch)
treec0635828628521eaa253b56db0e5178c39d42216
parent4ae927d69e5c2c6614805dbf02422d0c0a42c72f (diff)
downloadaur-9dae1c60464afc6eb7795e43d6b857ff225c14e1.tar.gz
Removing GLThreadedOptmizations by default
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--multithreaded-optimizations-opengl6
3 files changed, 3 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 838a31c79220..dc78b2e1bfbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvidia-dkms-performance
pkgdesc = NVIDIA driver sources for linux with some optimizations
pkgver = 460.39
- pkgrel = 1
+ pkgrel = 2
url = https://www.nvidia.com/
arch = x86_64
license = custom
@@ -13,7 +13,6 @@ pkgbase = nvidia-dkms-performance
conflicts = nvidia-dkms
source = https://us.download.nvidia.com/XFree86/Linux-x86_64/460.39/NVIDIA-Linux-x86_64-460.39-no-compat32.run
source = nvidia.hook
- source = multithreaded-optimizations-opengl
source = nvidia-settings-performance.desktop
source = nvidia-dkms-conf.patch
source = linux-rt.patch
@@ -21,7 +20,6 @@ pkgbase = nvidia-dkms-performance
source = NVreg.patch
sha256sums = 07042bd0c2f5c37b455a973f15561450f789590b8650a6ea573c819591d572a9
sha256sums = 717920f48b4d7ec50b83d2d096bab36449b30f1b5d144f0fe586627025367293
- sha256sums = 1237c8270cd4e3ae64f83642fe49f230190c247e5bd0ec0783183fc51c015382
sha256sums = 28635a9b0808beebff7e7905ee3e664d895fe23e149d462397c0b429c6f7d091
sha256sums = c84a4158083600191da80c22da146505f89d03374b3e0a5f71f8f2df6ad88004
sha256sums = cf4ee7cbc4200126ff25d649d11257eb1c7ade4aa0b313f31b56207f9fa73d4b
diff --git a/PKGBUILD b/PKGBUILD
index df30d0738a68..0fcd09d489aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pref_maximum_performance=
pkgname=nvidia-dkms-performance
pkgver=460.39
-pkgrel=1
+pkgrel=2
pkgdesc='NVIDIA driver sources for linux with some optimizations'
arch=('x86_64')
url='https://www.nvidia.com/'
@@ -17,7 +17,6 @@ conflicts=('nvidia' 'nvidia-dkms')
_pkg="NVIDIA-Linux-${CARCH}-${pkgver}-no-compat32"
source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run"
'nvidia.hook'
- 'multithreaded-optimizations-opengl'
'nvidia-settings-performance.desktop'
'nvidia-dkms-conf.patch'
'linux-rt.patch'
@@ -25,7 +24,6 @@ source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}
'NVreg.patch')
sha256sums=('07042bd0c2f5c37b455a973f15561450f789590b8650a6ea573c819591d572a9'
'717920f48b4d7ec50b83d2d096bab36449b30f1b5d144f0fe586627025367293'
- '1237c8270cd4e3ae64f83642fe49f230190c247e5bd0ec0783183fc51c015382'
'28635a9b0808beebff7e7905ee3e664d895fe23e149d462397c0b429c6f7d091'
'c84a4158083600191da80c22da146505f89d03374b3e0a5f71f8f2df6ad88004'
'cf4ee7cbc4200126ff25d649d11257eb1c7ade4aa0b313f31b56207f9fa73d4b'
@@ -83,15 +81,10 @@ package() {
install -D -m644 <(printf '%s\n%s\n' 'blacklist nouveau' 'options nouveau modeset=0') \
"${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
- # Enable multi-threaded OpenGL optimizations (env __GL_THREADED_OPTIMIZATIONS=1) by default for all applications.
- # Note: If you encounter an application that is incompatible with these optimizations,
- # please use the __GL_THREADED_OPTIMIZATIONS=0 environment variable.
- install -D -m644 "${srcdir}/multithreaded-optimizations-opengl" -t "${pkgdir}/etc/nvidia/nvidia-application-profiles-rc.d"
-
if [ -n "$_pref_maximum_performance" ]; then
install -D -m644 "${srcdir}/nvidia-settings-performance.desktop" -t "${pkgdir}/etc/xdg/autostart"
fi
# license
install -D -m644 "${_pkg}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
-} \ No newline at end of file
+}
diff --git a/multithreaded-optimizations-opengl b/multithreaded-optimizations-opengl
deleted file mode 100644
index 0abc954951e5..000000000000
--- a/multithreaded-optimizations-opengl
+++ /dev/null
@@ -1,6 +0,0 @@
-{
- "rules" : [
- { "pattern" : [],
- "profile" : [ "GLThreadedOptimizations", true ] }
- ]
-} \ No newline at end of file