summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-01-28 18:46:03 +0000
committerDaniel Bermond2020-01-28 18:46:03 +0000
commit0f53f83c79bbbf40ffe17d69f4ea06b3b921a9d3 (patch)
tree9887a1bd54ba597ddc5af238527850bb961fc297
parent227bc80ddc5ddd5a7f026e90df5319196b80e959 (diff)
downloadaur-0f53f83c79bbbf40ffe17d69f4ea06b3b921a9d3.tar.gz
Add fixes for linux 5.5, prime and FS#64317. Update xorg conf file.
- add patch to fix build for linux 5.5 (https://devtalk.nvidia.com/default/topic/1068332/linux/nvidia-driver-does-not-build-on-linux-v5-5-release-candidate-kernel/) - add patch to fix prime for linux 5.4 (https://devtalk.nvidia.com/default/topic/1068045/5-4-kernel-breaks-prime-synchronization-/) - remove patch for FS#62142 as reported by FS#64317
-rw-r--r--.SRCINFO12
-rw-r--r--110-nvidia-settings-full-beta-change-desktop-paths.patch (renamed from nvidia-settings-full-beta-change-desktop-paths.patch)0
-rw-r--r--FS62142.patch12
-rw-r--r--PKGBUILD25
-rw-r--r--nvidia-drm-outputclass.conf12
5 files changed, 19 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b0d38afcb2c..6d6b2360040c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvidia-full-beta
pkgdesc = Full NVIDIA driver package for Arch's official 'linux' package (drivers, utilities, and libraries) (beta version)
pkgver = 440.44
- pkgrel = 1
+ pkgrel = 2
url = https://www.nvidia.com/
arch = x86_64
license = custom
@@ -11,12 +11,14 @@ pkgbase = nvidia-full-beta
source = https://us.download.nvidia.com/XFree86/Linux-x86_64/440.44/NVIDIA-Linux-x86_64-440.44.run
source = nvidia-drm-outputclass.conf
source = nvidia-utils-full-beta.sysusers
- source = FS62142.patch
- source = nvidia-settings-full-beta-change-desktop-paths.patch
+ source = 010-nvidia-prime-kernel-5.4.patch::https://gitlab.com/snippets/1929174/raw
+ source = 020-nvidia-kernel-5.5.patch::https://gitlab.com/snippets/1923197/raw
+ source = 110-nvidia-settings-full-beta-change-desktop-paths.patch
sha256sums = ad427df2b619e6150291f9e03938dc8253769a59e900178c7f07d12d6ec2fc14
- sha256sums = 5519cdb420a45c15030f99c5c8c73eff322dc24b55d20e0167f0f5e97ebf0a97
+ sha256sums = be99ff3def641bb900c2486cce96530394c5dc60548fc4642f19d3a4c784134d
sha256sums = d8d1caa5d72c71c6430c2a0d9ce1a674787e9272ccce28b9d5898ca24e60a167
- sha256sums = c961006882afb691410c017c239e2c2ef61badb88f15735d37112b513ef0a99d
+ sha256sums = bedd55074771222bad8391c66b7022a266c135ff51d478710f7dda8708c3e9aa
+ sha256sums = 7dcd609e85720cb812d7b41320d845931d8ea3e8529c700231372e0da66e5804
sha256sums = 633bf69c39b8f35d0e64062eb0365c9427c2191583f2daa20b14e51772e8423a
pkgname = nvidia-full-beta
diff --git a/nvidia-settings-full-beta-change-desktop-paths.patch b/110-nvidia-settings-full-beta-change-desktop-paths.patch
index 97d02f608293..97d02f608293 100644
--- a/nvidia-settings-full-beta-change-desktop-paths.patch
+++ b/110-nvidia-settings-full-beta-change-desktop-paths.patch
diff --git a/FS62142.patch b/FS62142.patch
deleted file mode 100644
index 887f3366723e..000000000000
--- a/FS62142.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naurp a/kernel/nvidia/nv-dma.c b/kernel/nvidia/nv-dma.c
---- a/kernel/nvidia/nv-dma.c 2019-05-08 01:37:30.000000000 +0000
-+++ b/kernel/nvidia/nv-dma.c 2019-06-08 18:33:00.000000000 +0000
-@@ -613,7 +613,7 @@ static NvBool nv_dma_is_map_resource_imp
- #endif
- }
-
-- return (ops->map_resource != NULL);
-+ return (ops && ops->map_resource);
- #else
- return NV_FALSE;
- #endif
diff --git a/PKGBUILD b/PKGBUILD
index fc88d55b7ecf..7198928c9845 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Det <nimetonmaili g-mail>
pkgbase=nvidia-full-beta
@@ -9,7 +9,7 @@ pkgname=('nvidia-full-beta'
'lib32-nvidia-utils-full-beta'
'lib32-opencl-nvidia-full-beta')
pkgver=440.44
-pkgrel=1
+pkgrel=2
pkgdesc="Full NVIDIA driver package for Arch's official 'linux' package (drivers, utilities, and libraries) (beta version)"
arch=('x86_64')
url='https://www.nvidia.com/'
@@ -20,16 +20,16 @@ _pkg="NVIDIA-Linux-${CARCH}-${pkgver}"
source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run"
'nvidia-drm-outputclass.conf'
'nvidia-utils-full-beta.sysusers'
- 'FS62142.patch'
- 'nvidia-settings-full-beta-change-desktop-paths.patch')
+ '010-nvidia-prime-kernel-5.4.patch::https://gitlab.com/snippets/1929174/raw'
+ '020-nvidia-kernel-5.5.patch::https://gitlab.com/snippets/1923197/raw'
+ '110-nvidia-settings-full-beta-change-desktop-paths.patch')
sha256sums=('ad427df2b619e6150291f9e03938dc8253769a59e900178c7f07d12d6ec2fc14'
- '5519cdb420a45c15030f99c5c8c73eff322dc24b55d20e0167f0f5e97ebf0a97'
+ 'be99ff3def641bb900c2486cce96530394c5dc60548fc4642f19d3a4c784134d'
'd8d1caa5d72c71c6430c2a0d9ce1a674787e9272ccce28b9d5898ca24e60a167'
- 'c961006882afb691410c017c239e2c2ef61badb88f15735d37112b513ef0a99d'
+ 'bedd55074771222bad8391c66b7022a266c135ff51d478710f7dda8708c3e9aa'
+ '7dcd609e85720cb812d7b41320d845931d8ea3e8529c700231372e0da66e5804'
'633bf69c39b8f35d0e64062eb0365c9427c2191583f2daa20b14e51772e8423a')
-_extramodules='extramodules-ARCH'
-
# create soname links
_create_links() {
local _lib
@@ -51,10 +51,9 @@ prepare() {
sh "${_pkg}.run" --extract-only
bsdtar -C "$_pkg" -xf "${_pkg}/nvidia-persistenced-init.tar.bz2"
- patch -d "$_pkg" -Np1 -i "${srcdir}/nvidia-settings-full-beta-change-desktop-paths.patch"
-
- # fix https://bugs.archlinux.org/task/62142
- patch -d "$_pkg" -Np1 -i "${srcdir}/FS62142.patch"
+ patch -d "$_pkg" -Np1 -i "${srcdir}/010-nvidia-prime-kernel-5.4.patch"
+ patch -d "$_pkg" -Np1 -i "${srcdir}/020-nvidia-kernel-5.5.patch"
+ patch -d "$_pkg" -Np1 -i "${srcdir}/110-nvidia-settings-full-beta-change-desktop-paths.patch"
}
build() {
@@ -239,7 +238,7 @@ package_nvidia-utils-full-beta() {
# distro specific files must be installed in /usr/share/X11/xorg.conf.d
install -D -m644 "${srcdir}/nvidia-drm-outputclass.conf" "${pkgdir}/usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf"
- install -D -m644 "${srcdir}/nvidia-utils-full-beta.sysusers" -t "${pkgdir}/usr/lib/sysusers.d"
+ install -D -m644 "${srcdir}/nvidia-utils-full-beta.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
_create_links
}
diff --git a/nvidia-drm-outputclass.conf b/nvidia-drm-outputclass.conf
index 9eb1d698f79a..9c36f59b549e 100644
--- a/nvidia-drm-outputclass.conf
+++ b/nvidia-drm-outputclass.conf
@@ -1,20 +1,8 @@
-Section "ServerLayout"
- Identifier "layout"
- Option "AllowNVIDIAGPUScreens"
-EndSection
-
-Section "OutputClass"
- Identifier "intel"
- MatchDriver "i915"
- Driver "modesetting"
-EndSection
-
Section "OutputClass"
Identifier "nvidia"
MatchDriver "nvidia-drm"
Driver "nvidia"
Option "AllowEmptyInitialConfiguration"
- Option "PrimaryGPU" "yes"
ModulePath "/usr/lib/nvidia/xorg"
ModulePath "/usr/lib/xorg/modules"
EndSection