summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2017-12-11 22:39:12 +0200
committerDet2017-12-11 22:39:12 +0200
commit065e9608d2e9aac0b977e77e1139bf9d0a734d9b (patch)
treef45a02e615a654b1e9028b27b81869e31d2a9439
parent88c9a6e3ac167a30598baa6545ea72ecf60ad950 (diff)
downloadaur-065e9608d2e9aac0b977e77e1139bf9d0a734d9b.tar.gz
Fix & comment auto-patching further
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index baaca115ffc7..15c46b7d9dae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,10 +36,10 @@ md5sums=('a009bbc502c30e4b483d71be9fa51790'
#source+=('linux-4.11.patch')
#md5sums+=('cc8941b6898d9daa0fb67371f57a56b6')
-# Auto-detect patches (e.g. linux-4.19.patch)
-for _patch in $(find -maxdepth 1 -name '*.patch' -printf "%f\n"); do
- # Don't duplicate those already defined above (https://stackoverflow.com/a/15394738/1821548)
- if [[ ! " ${source[@]} " =~ " $_patch " ]]; then
+# Auto-detect *.patch
+for _patch in $(find "$startdir" -maxdepth 1 -name '*.patch' -printf "%f\n"); do
+ # Don't duplicate those already defined above
+ if [[ ! " ${source[@]} " =~ " $_patch " ]]; then # https://stackoverflow.com/a/15394738/1821548
source+=("$_patch")
md5sums+=('SKIP')
fi
@@ -74,7 +74,7 @@ prepare() {
cp -r kernel kernel-$_kernel
# Loop patches
- for _patch in $(printf -- '%s\n' ${source[@]} | grep .patch); do
+ for _patch in $(printf -- '%s\n' ${source[@]} | grep .patch); do # https://stackoverflow.com/a/21058239/1821548
# Patch version
_major_patch=$(echo $_patch | grep -Po "\d+\.\d+")