summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2017-12-08 23:53:52 +0200
committerDet2017-12-08 23:53:52 +0200
commita519db52ed2819b3e88c81e1eb78413eb95f8fda (patch)
tree3b71479af5c7868f77934f6681529e082c70d6f1
parentb2273fb21d58f14b63458fdc2515858c0d5daf34 (diff)
downloadaur-a519db52ed2819b3e88c81e1eb78413eb95f8fda.tar.gz
Update/improve kernel module comments
-rw-r--r--PKGBUILD43
1 files changed, 24 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f681f11b9ca..d532597e861c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -335,25 +335,30 @@ package_nvidia-full-beta-all() {
for _path in $(find /usr/lib/modules/extramodules-*/version -printf '%h\n'); do
_extramodules=$(cat $_path/version)
- # Install
- install -Dm644 $_pkg/kernel-$_extramodules/nvidia.ko \
- "$pkgdir"/$_path/nvidia.ko
-
- # Install UVM Module: http://devblogs.nvidia.com/parallelforall/unified-memory-in-cuda-6/
- install -Dm644 $_pkg/kernel-$_extramodules/nvidia-uvm.ko \
- "$pkgdir"/$_path/nvidia-uvm.ko
-
- # Install Modeset module:
- #
- # "nvidia-modeset.ko does not provide any new user-visible functionality or interfaces to third party applications.
- # However, in a later release, nvidia-modeset.ko will be used as a basis for the modesetting interface provided by
- # the kernel's direct rendering manager (DRM)."
- install -Dm644 $_pkg/kernel-$_extramodules/nvidia-modeset.ko \
- "$pkgdir"/$_path/nvidia-modeset.ko
-
- # Install DRM module ("registers as a DRM driver with both PRIME and DRM KMS support")
- install -Dm644 $_pkg/kernel-$_extramodules/nvidia-drm.ko \
- "$pkgdir"/$_path/nvidia-drm.ko
+ # Nvidia kernel module; provides low-level access to your NVIDIA hardware for the other components. Generally
+ # loaded into the kernel when the X server is started, to be used by the X driver and OpenGL. Consists of two
+ # pieces: the binary-only core, and a kernel interface that must be compiled specifically for your kernel version,
+ # because the Linux kernel doesn't have a consistent binary interface like the X server.
+ install -Dm644 $_pkg/kernel-$_extramodules/nvidia.ko \
+ "$pkgdir"/$_path/nvidia.ko
+
+ # NVIDIA Unified Memory kernel module; provides functionality for sharing memory between the CPU and GPU in
+ # CUDA programs. Generally loaded into the kernel when a CUDA program is started, and used by the CUDA
+ # driver on supported platforms: http://devblogs.nvidia.com/parallelforall/unified-memory-in-cuda-6/
+ install -Dm644 $_pkg/kernel-$_extramodules/nvidia-uvm.ko \
+ "$pkgdir"/$_path/nvidia-uvm.ko
+
+ # Kernel module responsible for programming the display engine of the GPU. User-mode NVIDIA driver components
+ # such as the NVIDIA X driver, OpenGL driver, and VDPAU driver communicate with nvidia-modeset.ko through the
+ # /dev/nvidia-modeset device file.
+ install -Dm644 $_pkg/kernel-$_extramodules/nvidia-modeset.ko \
+ "$pkgdir"/$_path/nvidia-modeset.ko
+
+ # NVIDIA DRM kernel module; registers as a DRM driver to provide GEM and PRIME DRM capabilities
+ # for atomic DRM KMS and graphics display offload on Optimus notebooks:
+ # https://devtalk.nvidia.com/default/topic/925605/linux/nvidia-364-12-release-vulkan-glvnd-drm-kms-and-eglstreams/
+ install -Dm644 $_pkg/kernel-$_extramodules/nvidia-drm.ko \
+ "$pkgdir"/$_path/nvidia-drm.ko
# Compress
gzip "$pkgdir"/$_path/nvidia*.ko