summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Playfair Cal2017-05-08 15:08:49 +1000
committerDaniel Playfair Cal2017-05-08 15:08:49 +1000
commitb684890639a54f46043733be5b6e25fdce09e7f4 (patch)
tree77a09e5350f68631f0cdf6b4a941391363e342cc
parent463195bfc4099d65eec2696c0e889e928e1492f9 (diff)
downloadaur-nvidia-llb-dkms.tar.gz
375.66-2 add patch for kernel 4.11
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--kernel_4.11.patch24
3 files changed, 34 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3a12a40ed1a..7aba5a7e2ad8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvidia-llb-dkms
pkgdesc = NVIDIA kernel module sources (DKMS) - long lived branch
pkgver = 375.66
- pkgrel = 1
+ pkgrel = 2
url = http://www.nvidia.com/
install = nvidia-llb-dkms.install
arch = i686
@@ -10,7 +10,7 @@ pkgbase = nvidia-llb-dkms
license = custom:NVIDIA
depends = dkms
depends = linux>=3.7
- depends = linux<4.11
+ depends = linux<4.12
depends = nvidia-utils-llb>=375.66
depends = libgl
optdepends = linux-headers: Build the module for Arch kernel
@@ -25,6 +25,8 @@ pkgbase = nvidia-llb-dkms
md5sums_x86_64 = 361843d4b714a9876b3599fd8dca2412
source_armv7h = http://us.download.nvidia.com/XFree86/Linux-x86-ARM/375.66/NVIDIA-Linux-armv7l-gnueabihf-375.66.run
md5sums_armv7h = d8f8bee37b237f76c533eb0c4dae9bbc
+ source = kernel_4.11.patch
+ md5sums = a8f4a6736f77d06112111cedc98ceea5
pkgname = nvidia-llb-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 5c56abd253be..00fb4ff617a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@
pkgname=nvidia-llb-dkms
pkgver=375.66
-pkgrel=1
+pkgrel=2
pkgdesc="NVIDIA kernel module sources (DKMS) - long lived branch"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.nvidia.com/"
license=('custom:NVIDIA')
-depends=('dkms' 'linux>=3.7' 'linux<4.11' "nvidia-utils-llb>=${pkgver}" 'libgl')
+depends=('dkms' 'linux>=3.7' 'linux<4.12' "nvidia-utils-llb>=${pkgver}" 'libgl')
optdepends=('linux-headers: Build the module for Arch kernel'
'linux-lts-headers: Build the module for LTS Arch kernel')
provides=("nvidia=${pkgver}" 'nvidia-dkms')
@@ -23,9 +23,11 @@ install=${pkgname}.install
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
source_armv7h=("http://us.download.nvidia.com/XFree86/Linux-x86-ARM/${pkgver}/NVIDIA-Linux-armv7l-gnueabihf-${pkgver}.run")
+source=('kernel_4.11.patch')
# http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run.md5
# http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run.md5
# http://us.download.nvidia.com/XFree86/Linux-x86-ARM/${pkgver}/NVIDIA-Linux-armv7l-gnueabihf-${pkgver}.run.md5
+md5sums=('a8f4a6736f77d06112111cedc98ceea5')
md5sums_i686=('47dddb796fe39497cf6ae374591f6eb9')
md5sums_x86_64=('361843d4b714a9876b3599fd8dca2412')
md5sums_armv7h=('d8f8bee37b237f76c533eb0c4dae9bbc')
@@ -44,6 +46,8 @@ prepare() {
sh ${_pkg}.run --extract-only
cd ${_pkg}/kernel
# patches here
+ # Patch for licensing issue on 4.11
+ patch -p1 -i "${srcdir}/kernel_4.11.patch"
# Update dkms.conf
sed -e "s/__VERSION_STRING/${pkgver}/" \
diff --git a/kernel_4.11.patch b/kernel_4.11.patch
new file mode 100644
index 000000000000..989095e1d8b9
--- /dev/null
+++ b/kernel_4.11.patch
@@ -0,0 +1,24 @@
+--- a/nvidia-drm/nvidia-drm-linux.c
++++ b/nvidia-drm/nvidia-drm-linux.c
+@@ -20,6 +20,8 @@
+ * DEALINGS IN THE SOFTWARE.
+ */
+
++#include <linux/version.h>
++
+ #include <linux/module.h>
+ #include <linux/slab.h>
+ #include <linux/err.h>
+@@ -196,7 +198,11 @@
+ module_exit(nv_linux_drm_exit);
+
+ #if defined(MODULE_LICENSE)
++#if LINUX_VERSION_CODE > KERNEL_VERSION(4, 10, 0)
++ MODULE_LICENSE("Dual MIT/GPL");
++#else
+ MODULE_LICENSE("MIT");
++#endif
+ #endif
+ #if defined(MODULE_INFO)
+ MODULE_INFO(supported, "external");
+