summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2015-11-13 17:02:01 +0100
committersirlucjan2015-11-13 17:02:01 +0100
commit59039eed0d2287d85f69b86fb7f7abc0a6dc8cdc (patch)
tree73a0794b225a97a587bff023717bbbc38b96fd29
parenta07b689c13c161e9eff333118d3932d6169f091f (diff)
downloadaur-59039eed0d2287d85f69b86fb7f7abc0a6dc8cdc.tar.gz
Bump to 4.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
-rw-r--r--nvidia-4.3-build.patch20
-rw-r--r--nvidia-lqx.install2
4 files changed, 41 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7146179f1497..e8923fdbfd54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = nvidia-lqx
pkgdesc = NVIDIA drivers for linux-lqx
pkgver = 355.11
- pkgrel = 3
+ pkgrel = 6
url = http://www.nvidia.com/
install = nvidia-lqx.install
arch = i686
arch = x86_64
license = custom
- makedepends = linux-lqx-headers>=4.2
- makedepends = linux-lqx-headers<4.3
- depends = linux-lqx>=4.2
- depends = linux-lqx<4.3
+ makedepends = linux-lqx-headers>=4.3
+ makedepends = linux-lqx-headers<4.4
+ depends = linux-lqx>=4.3
+ depends = linux-lqx<4.4
depends = nvidia-libgl
depends = nvidia-utils=355.11
conflicts = nvidia-304xx-lqx
conflicts = nvidia-340xx-lqx
options = !strip
+ source = nvidia-4.3-build.patch
+ md5sums = 1e5f60cf8e77af482345549b9436887a
source_i686 = ftp://download.nvidia.com/XFree86/Linux-x86/355.11/NVIDIA-Linux-x86-355.11.run
md5sums_i686 = 16d143ccafe99328a2ca8e5a396fd4bc
source_x86_64 = ftp://download.nvidia.com/XFree86/Linux-x86_64/355.11/NVIDIA-Linux-x86_64-355.11-no-compat32.run
diff --git a/PKGBUILD b/PKGBUILD
index 032711be54d4..6f396ae13910 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,33 @@
pkgname=nvidia-lqx
pkgver=355.11
-_extramodules=extramodules-4.2-lqx
-pkgrel=3
+_extramodules=extramodules-4.3-lqx
+pkgrel=6
pkgdesc="NVIDIA drivers for linux-lqx"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-lqx>=4.2' 'linux-lqx<4.3' "nvidia-libgl" "nvidia-utils=${pkgver}")
-makedepends=('linux-lqx-headers>=4.2' 'linux-lqx-headers<4.3')
+depends=('linux-lqx>=4.3' 'linux-lqx<4.4' "nvidia-libgl" "nvidia-utils=${pkgver}")
+makedepends=('linux-lqx-headers>=4.3' 'linux-lqx-headers<4.4')
conflicts=('nvidia-304xx-lqx' 'nvidia-340xx-lqx')
license=('custom')
install=nvidia-lqx.install
options=(!strip)
-source_i686+=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
-source_x86_64+=("ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums_i686=('16d143ccafe99328a2ca8e5a396fd4bc')
-md5sums_x86_64=('30133d89690f4683c4e289ec6c0247dc')
+source=('nvidia-4.3-build.patch')
+source_i686="ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
+source_x86_64="ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run"
+md5sums=('1e5f60cf8e77af482345549b9436887a')
+md5sums_i686='16d143ccafe99328a2ca8e5a396fd4bc'
+md5sums_x86_64='30133d89690f4683c4e289ec6c0247dc'
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
-prepare() {
+prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
# patches here
+ patch -Np1 -i ${srcdir}/nvidia-4.3-build.patch
+
}
build() {
diff --git a/nvidia-4.3-build.patch b/nvidia-4.3-build.patch
new file mode 100644
index 000000000000..1d13fd8706f4
--- /dev/null
+++ b/nvidia-4.3-build.patch
@@ -0,0 +1,20 @@
+--- a/kernel/nvidia/nv-procfs.c
++++ b/kernel/nvidia/nv-procfs.c
+@@ -360,7 +360,8 @@ nv_procfs_read_registry(
+ registry_keys = ((nvl != NULL) ?
+ nvl->registry_keys : nv_registry_keys);
+
+- return seq_printf(s, "Binary: \"%s\"\n", registry_keys);
++ seq_printf(s, "Binary: \"%s\"\n", registry_keys);
++ return 0;
+ }
+
+ static ssize_t
+@@ -560,7 +561,8 @@ nv_procfs_read_text_file(
+ void *v
+ )
+ {
+- return seq_puts(s, s->private);
++ seq_puts(s, s->private);
++ return 0;
+ }
diff --git a/nvidia-lqx.install b/nvidia-lqx.install
index 36756505a0eb..04cff03c7ff8 100644
--- a/nvidia-lqx.install
+++ b/nvidia-lqx.install
@@ -1,5 +1,5 @@
post_install() {
- EXTRAMODULES='extramodules-4.2-lqx'
+ EXTRAMODULES='extramodules-4.3-lqx'
depmod $(cat /usr/lib/modules/${EXTRAMODULES}/version)
echo 'In order to use nvidia module, reboot the system.'
}