summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfaaris2022-05-29 23:10:58 +0100
committerfaaris2022-05-29 23:10:58 +0100
commitd98c402b4884c03465be9f63e72c2299ad48c14a (patch)
tree0026165d1e4bdd7dc47b31a16af99c76918cd6ca
parent005b4b707fe6d7441794ca10456025106cb0620b (diff)
downloadaur-d98c402b4884c03465be9f63e72c2299ad48c14a.tar.gz
fix script
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--nvidia-modprobe.service10
-rw-r--r--nvidia.shutdown4
4 files changed, 13 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21863df8f32e..c60f530b108a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = nvidia-modprobe-service
pkgdesc = Fixes /oldroot unmount issues by unloading nvidia modules before shutdown / reboot.
- pkgver = 1
- pkgrel = 10
+ pkgver = 2
+ pkgrel = 1
url = https://github.com/Fxzzi/nvidia-modprobe-service
install = notes.install
arch = any
license = GPL
depends = systemd
- source = nvidia-modprobe.service
+ source = nvidia.shutdown
source = notes.install
- sha256sums = 1895e120c20c841187a743916a71f9957e5da519e45f12565266fa5370b71beb
+ sha256sums = 70887ad4e0a2759aeb929514287e83c5b01016bfb8e19098b42d7fb11dcd5af6
sha256sums = c105f4a328491f31984d767bc15042122d4de59cca4c3d46fbd7712004053982
pkgname = nvidia-modprobe-service
diff --git a/PKGBUILD b/PKGBUILD
index 2747eccae1f6..c3814d673434 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fazzi <faarisansari@googlemail.com>
pkgname=nvidia-modprobe-service
-pkgver=1
-pkgrel=10
+pkgver=2
+pkgrel=1
pkgdesc="Fixes /oldroot unmount issues by unloading nvidia modules before shutdown / reboot."
arch=('any')
license=('GPL')
@@ -10,13 +10,13 @@ depends=('systemd')
install="notes.install"
url="https://github.com/Fxzzi/nvidia-modprobe-service"
-source=('nvidia-modprobe.service'
+source=('nvidia.shutdown'
'notes.install')
-sha256sums=('1895e120c20c841187a743916a71f9957e5da519e45f12565266fa5370b71beb'
+sha256sums=('70887ad4e0a2759aeb929514287e83c5b01016bfb8e19098b42d7fb11dcd5af6'
'c105f4a328491f31984d767bc15042122d4de59cca4c3d46fbd7712004053982')
package() {
- install -Dm 644 nvidia-modprobe.service -t "$pkgdir"/usr/lib/systemd/system/
+ install -Dm 644 nvidia.shutdown -t "$pkgdir"/usr/lib/systemd/system-shutdown/
}
diff --git a/nvidia-modprobe.service b/nvidia-modprobe.service
deleted file mode 100644
index 46feda07af18..000000000000
--- a/nvidia-modprobe.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Ditch nvidia after multi-user.target
-
-[Service]
-Type=oneshot
-RemainAfterExit=true
-ExecStop=/usr/bin/modprobe -r nvidia_drm nvidia_modeset nvidia_uvm nvidia
-
-[Install]
-WantedBy=multi-user.target
diff --git a/nvidia.shutdown b/nvidia.shutdown
new file mode 100644
index 000000000000..7a86cdb64594
--- /dev/null
+++ b/nvidia.shutdown
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+# remove nvidia modules
+/usr/bin/modprobe -r nvidia_drm nvidia_modeset nvidia_uvm nvidia