summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-06-24 19:27:12 +0200
committerjose17112016-06-24 19:27:12 +0200
commit88cae33ce709f39c0f2c4ddfe0c18c206780d405 (patch)
tree798c160e83a5d769fc28598978b2c8329d186f19
parentc2585e9891f39450ee5abf6369ff038a305cb11f (diff)
downloadaur-88cae33ce709f39c0f2c4ddfe0c18c206780d405.tar.gz
updated
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
-rw-r--r--linux-4.6.patch50
3 files changed, 10 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f31aa6e7293b..a8cf4834e826 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,33 @@
# Generated by mksrcinfo v8
-# Sat Jun 11 16:37:30 UTC 2016
+# Fri Jun 24 17:24:17 UTC 2016
pkgbase = nvidia-pae
pkgdesc = NVIDIA drivers for linux
- pkgver = 364.19
+ pkgver = 367.27
pkgrel = 1
url = http://www.nvidia.com/
arch = i686
license = custom
makedepends = nvidia-libgl
- makedepends = nvidia-utils=364.19
+ makedepends = nvidia-utils=367.27
makedepends = linux-pae
makedepends = linux-pae-headers>=4.6
makedepends = linux-pae-headers<4.7
options = !strip
- source = http://us.download.nvidia.com/XFree86/Linux-x86/364.19/NVIDIA-Linux-x86-364.19.run
- source = linux-4.6.patch
- md5sums = 8a4015213c4a8f1c80e9520d04a32a7b
- md5sums = 3064bd437b26adac246f301f54f2814c
+ source = http://us.download.nvidia.com/XFree86/Linux-x86/367.27/NVIDIA-Linux-x86-367.27.run
+ md5sums = f32b9ab673acce56990f2b5acdc1e77f
pkgname = nvidia-pae
pkgdesc = NVIDIA drivers for linux
install = nvidia.install
depends = linux-pae>=4.6
depends = linux-pae<4.7
- depends = nvidia-utils=364.19
+ depends = nvidia-utils=367.27
depends = libgl
pkgname = nvidia-pae-dkms
pkgdesc = NVIDIA driver sources for linux
depends = dkms
- depends = nvidia-utils=364.19
+ depends = nvidia-utils=367.27
depends = libgl
optdepends = linux-pae-headers: Build the module for Arch PAE kernel
optdepends = linux-lts-headers: Build the module for LTS Arch kernel
diff --git a/PKGBUILD b/PKGBUILD
index d4ba7d65a3c3..e90180e6bf62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=nvidia-pae
pkgname=(nvidia-pae nvidia-pae-dkms)
-pkgver=364.19
+pkgver=367.27
_extramodules=extramodules-4.6-pae
pkgrel=1
pkgdesc="NVIDIA drivers for linux"
@@ -15,9 +15,8 @@ makedepends=('nvidia-libgl' "nvidia-utils=${pkgver}" 'linux-pae' 'linux-pae-head
license=('custom')
options=('!strip')
# See nvidia-utils
-source=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run" 'linux-4.6.patch')
-md5sums=('8a4015213c4a8f1c80e9520d04a32a7b'
- '3064bd437b26adac246f301f54f2814c')
+source=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+md5sums=('f32b9ab673acce56990f2b5acdc1e77f')
_pkg="NVIDIA-Linux-x86-${pkgver}"
@@ -25,7 +24,6 @@ prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
# patches here
- patch -p1 --no-backup-if-mismatch -i ../linux-4.6.patch
cp -a kernel kernel-dkms
cd kernel-dkms
diff --git a/linux-4.6.patch b/linux-4.6.patch
deleted file mode 100644
index 3dde4730532b..000000000000
--- a/linux-4.6.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- a/kernel/nvidia-drm/nvidia-drm-fb.c
-+++ b/kernel/nvidia-drm/nvidia-drm-fb.c
-@@ -77,7 +77,7 @@
- static struct drm_framebuffer *internal_framebuffer_create
- (
- struct drm_device *dev,
-- struct drm_file *file, struct drm_mode_fb_cmd2 *cmd,
-+ struct drm_file *file, const struct drm_mode_fb_cmd2 *cmd,
- uint64_t nvkms_params_ptr,
- uint64_t nvkms_params_size
- )
-@@ -199,7 +199,7 @@
- struct drm_framebuffer *nvidia_drm_framebuffer_create
- (
- struct drm_device *dev,
-- struct drm_file *file, struct drm_mode_fb_cmd2 *cmd
-+ struct drm_file *file, const struct drm_mode_fb_cmd2 *cmd
- )
- {
- return internal_framebuffer_create(dev, file, cmd, 0, 0);
---- a/kernel/nvidia-drm/nvidia-drm-fb.h
-+++ b/kernel/nvidia-drm/nvidia-drm-fb.h
-@@ -45,7 +45,7 @@
- struct drm_framebuffer *nvidia_drm_framebuffer_create
- (
- struct drm_device *dev,
-- struct drm_file *file, struct drm_mode_fb_cmd2 *cmd
-+ struct drm_file *file, const struct drm_mode_fb_cmd2 *cmd
- );
-
- int nvidia_drm_add_nvkms_fb(
---- a/kernel/nvidia-drm/nvidia-drm-linux.c
-+++ b/kernel/nvidia-drm/nvidia-drm-linux.c
-@@ -31,6 +31,7 @@
-
- #if defined(NV_DRM_AVAILABLE)
-
-+#include "nv-mm.h"
- #include "nv-pgprot.h"
-
- MODULE_PARM_DESC(
-@@ -121,8 +122,7 @@
-
- down_read(&mm->mmap_sem);
-
-- pages_pinned = get_user_pages(current, mm,
-- address, pages_count, write, force,
-+ pages_pinned = NV_GET_USER_PAGES(address, pages_count, write, force,
- user_pages, NULL);
- up_read(&mm->mmap_sem); \ No newline at end of file