summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBeanieBen99902021-12-01 14:51:11 -0500
committerBeanieBen99902021-12-01 14:51:11 -0500
commitc0a2e205e78d544f3b05100684407f4ba8642ed9 (patch)
tree97cd41feeb5b8d5438c13147dc7188b27fde0047
downloadaur-c0a2e205e78d544f3b05100684407f4ba8642ed9.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD49
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3970c3cf99f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nvidia-prime-select-git
+ pkgdesc = A collection of shell scripts that makes it possible to use the NVIDIA GPU on a Optimus Laptop, similar to the feature provided by the nvidia-prime package in Ubuntu. Forked by wildtruc
+ pkgver = 20191010.902aa9a
+ pkgrel = 1
+ url = https://github.com/wildtruc/nvidia-prime-select
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = nvidia
+ provides = nvidia-prime-select
+ conflicts = nvidia-prime-select
+ source = nvidia-prime-select::git+https://github.com/wildtruc/nvidia-prime-select.git
+ sha1sums = SKIP
+
+pkgname = nvidia-prime-select-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25441162e126
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: beanie
+
+_pkgname=nvidia-prime-select
+pkgname=${_pkgname}-git
+pkgver=20191010.902aa9a
+pkgrel=1
+pkgdesc='A collection of shell scripts that makes it possible to use the NVIDIA GPU on a Optimus Laptop, similar to the feature provided by the nvidia-prime package in Ubuntu. Forked by wildtruc'
+
+url='https://github.com/wildtruc/nvidia-prime-select'
+arch=('any')
+license=('GPL')
+
+depends=('nvidia')
+makedepends=('git')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+source=("${_pkgname}::git+https://github.com/wildtruc/nvidia-prime-select.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}"
+ bash -n *.sh
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 nvidia-prime-ui usr/bin
+ install -Dm755 nvidia-prime-select usr/sbin
+ install -Dm644 xorg.nvidia.conf etc/nvidia-prime
+ install -Dm644 xorg.offload.conf etc/nvidia-prime
+ install -Dm644 xorg.intel.conf etc/nvidia-prime
+ install -Dm644 library.conf etc/nvidia-prime
+ install -Dm644 options.conf etc/nvidia-prime
+ install -Dm644 report.sample etc/nvidia-prime
+ install -Dm644 nvidia-prime.desktop etc/nvidia-prime
+ install -Dm644 nvidia-session.desktop etc/nvidia-prime
+ install -Dm644 nvidia-prime.png usr/share/pixmaps
+ install -Dm644 nvidia-prime-ui.desktop usr/share/applications
+ install -Dm644 com.github.pkexec.nvidia-prime-select.policy usr/share/polkit-1/actions
+ install -Dm644 com.github.pkexec.nvidia-prime-editor.policy usr/share/polkit-1/actions
+ bash ./changelog.sh
+}