summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-02-02 08:31:17 +0100
committertytan6522022-02-02 08:31:17 +0100
commit33dab5a8a2bc4c1f98c0662b0b00d3da748c7895 (patch)
treee734458e59050faaf5e3ea4bda1df8e013de8d69
parent287e6ceeeb6d94966e7adf34963d626a2015b6d4 (diff)
downloadaur-33dab5a8a2bc4c1f98c0662b0b00d3da748c7895.tar.gz
build: Add nvidia-powerd support
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a60852e26594..8a5880264a0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvidia-utils-beta-nvlax
pkgdesc = NVIDIA drivers utilities (beta version) with NVENC and NvFBC patched with nvlax
pkgver = 510.47.03
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/illnyang/nvlax/
install = nvidia-utils-beta.install
arch = x86_64
@@ -21,6 +21,7 @@ pkgbase = nvidia-utils-beta-nvlax
provides = opengl-driver
provides = nvidia-libgl
conflicts = nvidia-libgl
+ conflicts = nvidia-fake-powerd
replaces = nvidia-libgl
options = !strip
options = !ccache
diff --git a/PKGBUILD b/PKGBUILD
index 04fce6d2fa8b..1e87617ca152 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=nvidia-utils-beta
pkgname=${_pkgname}-nvlax
pkgver=510.47.03
-pkgrel=1
+pkgrel=2
pkgdesc="NVIDIA drivers utilities (beta version) with NVENC and NvFBC patched with nvlax"
arch=('x86_64')
license=('custom')
@@ -19,6 +19,7 @@ optdepends=(
)
conflicts=(
'nvidia-libgl'
+ 'nvidia-fake-powerd'
)
provides=(
"${_pkgname}=${pkgver}"
@@ -202,11 +203,11 @@ package() {
ln -s nvidia "${pkgdir}/usr/share/doc/${_pkgname}"
# new power management support
- install -Dm644 systemd/system/nvidia-suspend.service "${pkgdir}/usr/lib/systemd/system/nvidia-suspend.service"
- install -Dm644 systemd/system/nvidia-hibernate.service "${pkgdir}/usr/lib/systemd/system/nvidia-hibernate.service"
- install -Dm644 systemd/system/nvidia-resume.service "${pkgdir}/usr/lib/systemd/system/nvidia-resume.service"
+ install -Dm644 systemd/system/*.service -t "${pkgdir}/usr/lib/systemd/system"
install -Dm755 systemd/system-sleep/nvidia "${pkgdir}/usr/lib/systemd/system-sleep/nvidia"
install -Dm755 systemd/nvidia-sleep.sh "${pkgdir}/usr/bin/nvidia-sleep.sh"
+ install -Dm755 nvidia-powerd "${pkgdir}/usr/bin/nvidia-powerd"
+ install -Dm644 nvidia-dbus.conf "${pkgdir}"/usr/share/dbus-1/system.d/nvidia-dbus.conf
# distro specific files must be installed in /usr/share/X11/xorg.conf.d
install -Dm644 "${srcdir}/nvidia-drm-outputclass.conf" "${pkgdir}/usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf"