summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Stryker2019-02-19 15:01:50 -0500
committerJason Stryker2019-02-19 15:01:50 -0500
commit76dbb12bbc013679bd06b31d771a152bdc89abad (patch)
tree27d4b2107d860855522c35700240752aa0260fd3
parente3e8aab443c5c33b1ef0de63d648a863f82ed455 (diff)
downloadaur-76dbb12bbc013679bd06b31d771a152bdc89abad.tar.gz
update to driver version 418.31.03
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD15
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b1d101050c..adac50f7de6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nvidia-vulkan
pkgdesc = NVIDIA drivers for linux (vulkan developer branch)
- pkgver = 415.22.05
+ pkgver = 418.31.03
pkgrel = 1
url = https://developer.nvidia.com/vulkan-driver
arch = x86_64
@@ -10,11 +10,11 @@ pkgbase = nvidia-vulkan
makedepends = linux-headers>=4.20
makedepends = linux-headers<4.21
options = !strip
- source = NVIDIA-Linux-x86_64-415.22.05.run::https://developer.nvidia.com/vulkan-beta-4152205-linux
+ source = NVIDIA-Linux-x86_64-418.31.03.run::https://developer.nvidia.com/vulkan-beta-4183103-linux
source = nvidia-drm-outputclass.conf
source = nvidia-vulkan-utils.sysusers
source = kernel-4.16.patch
- sha512sums = f5ad764634113e06ddfdc55e45439bf71f4eaafba88881f7d5570721770a016161471e149a779111dc866275425e418aae641879f41368b057b2dbf6e0508196
+ sha512sums = 9d4af0a6a46ca0e27de97c6daa038367966b48e0c08c979a284976902de4e8daa72ae49a46b8539457d580939ad8709d3f3ee7041279bedbbeb03786abdf37ac
sha512sums = c49d246a519731bfab9d22afa5c2dd2d366db06d80182738b84881e93cd697c783f16ee04819275c05597bb063451a5d6102fbc562cd078d2a374533a23cea48
sha512sums = 4b3ad73f5076ba90fe0b3a2e712ac9cde76f469cd8070280f960c3ce7dc502d1927f525ae18d008075c8f08ea432f7be0a6c3a7a6b49c361126dcf42f97ec499
sha512sums = ad1185d998adbf89abf7aea300e5b3bbabe2296016f42592fbc232a6c3983f233df1103d37f35a041f12cc1c722d3edce813a4a1b215784a49c7f0e3e652b5af
@@ -23,19 +23,19 @@ pkgname = nvidia-vulkan
pkgdesc = NVIDIA drivers for linux (vulkan developer branch)
depends = linux>=4.20
depends = linux<4.21
- depends = nvidia-vulkan-utils=415.22.05
+ depends = nvidia-vulkan-utils=418.31.03
depends = libglvnd
- provides = nvidia=415.22.05
+ provides = nvidia=418.31.03
conflicts = nvidia
pkgname = nvidia-vulkan-dkms
pkgdesc = NVIDIA driver sources for linux (vulkan developer branch)
depends = dkms
- depends = nvidia-vulkan-utils=415.22.05
+ depends = nvidia-vulkan-utils=418.31.03
depends = libglvnd
optdepends = linux-headers: Build the module for Arch kernel
optdepends = linux-lts-headers: Build the module for LTS Arch kernel
- provides = nvidia=415.22.05
+ provides = nvidia=418.31.03
conflicts = nvidia
pkgname = nvidia-vulkan-utils
@@ -48,7 +48,7 @@ pkgname = nvidia-vulkan-utils
optdepends = gtk3: nvidia-settings (GTK+ v3)
optdepends = xorg-server-devel: nvidia-xconfig
optdepends = opencl-nvidia-vulkan: OpenCL support
- provides = nvidia-utils=415.22.05
+ provides = nvidia-utils=418.31.03
provides = vulkan-driver
provides = opengl-driver
provides = nvidia-libgl
@@ -63,7 +63,7 @@ pkgname = opencl-nvidia-vulkan
depends = zlib
optdepends = opencl-headers: headers necessary for OpenCL development
provides = opencl-driver
- provides = opencl-nvidia=415.22.05
+ provides = opencl-nvidia=418.31.03
conflicts = opencl-nvidia
pkgname = lib32-nvidia-vulkan-utils
@@ -73,7 +73,7 @@ pkgname = lib32-nvidia-vulkan-utils
depends = lib32-libglvnd
depends = nvidia-vulkan-utils
optdepends = lib32-opencl-nvidia-vulkan
- provides = lib32-nvidia-utils=415.22.05
+ provides = lib32-nvidia-utils=418.31.03
provides = lib32-vulkan-driver
provides = lib32-opengl-driver
provides = lib32-nvidia-libgl
@@ -87,7 +87,7 @@ pkgname = lib32-opencl-nvidia-vulkan
depends = lib32-gcc-libs
optdepends = opencl-headers: headers necessary for OpenCL development
provides = lib32-opencl-driver
- provides = lib32-opencl-nvidia=415.22.05
+ provides = lib32-opencl-nvidia=418.31.03
conflicts = lib32-opencl-nvidia
conflicts = lib32-opencl-nvidia-390xx
diff --git a/PKGBUILD b/PKGBUILD
index b225293ca4c..5cb2dae5357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=nvidia-vulkan
pkgname=('nvidia-vulkan' 'nvidia-vulkan-dkms' 'nvidia-vulkan-utils' 'opencl-nvidia-vulkan' 'lib32-nvidia-vulkan-utils' 'lib32-opencl-nvidia-vulkan')
-pkgver=415.22.05
+pkgver=418.31.03
_extramodules=extramodules-ARCH
pkgrel=1
pkgdesc="NVIDIA drivers for linux (vulkan developer branch)"
@@ -17,11 +17,11 @@ makedepends=('libglvnd' 'linux' 'linux-headers>=4.20' 'linux-headers<4.21')
license=('custom')
options=('!strip')
_pkg="NVIDIA-Linux-x86_64-${pkgver}"
-source=("${_pkg}.run::https://developer.nvidia.com/vulkan-beta-4152205-linux"
+source=("${_pkg}.run::https://developer.nvidia.com/vulkan-beta-4183103-linux"
'nvidia-drm-outputclass.conf'
'nvidia-vulkan-utils.sysusers'
'kernel-4.16.patch')
-sha512sums=('f5ad764634113e06ddfdc55e45439bf71f4eaafba88881f7d5570721770a016161471e149a779111dc866275425e418aae641879f41368b057b2dbf6e0508196'
+sha512sums=('9d4af0a6a46ca0e27de97c6daa038367966b48e0c08c979a284976902de4e8daa72ae49a46b8539457d580939ad8709d3f3ee7041279bedbbeb03786abdf37ac'
'c49d246a519731bfab9d22afa5c2dd2d366db06d80182738b84881e93cd697c783f16ee04819275c05597bb063451a5d6102fbc562cd078d2a374533a23cea48'
'4b3ad73f5076ba90fe0b3a2e712ac9cde76f469cd8070280f960c3ce7dc502d1927f525ae18d008075c8f08ea432f7be0a6c3a7a6b49c361126dcf42f97ec499'
'ad1185d998adbf89abf7aea300e5b3bbabe2296016f42592fbc232a6c3983f233df1103d37f35a041f12cc1c722d3edce813a4a1b215784a49c7f0e3e652b5af')
@@ -150,9 +150,6 @@ package_nvidia-vulkan-utils() {
ln -s "libglxserver_nvidia.so.${pkgver}" "${pkgdir}/usr/lib/nvidia/xorg/libglxserver_nvidia.so.1"
ln -s "libglxserver_nvidia.so.${pkgver}" "${pkgdir}/usr/lib/nvidia/xorg/libglxserver_nvidia.so"
- # X wrapped software rendering
- install -D -m755 "libnvidia-wfb.so.${pkgver}" "${pkgdir}/usr/lib/libnvidia-wfb.so.${pkgver}"
-
install -D -m755 "libGLX_nvidia.so.${pkgver}" "${pkgdir}/usr/lib/libGLX_nvidia.so.${pkgver}"
# OpenGL libraries
@@ -198,6 +195,9 @@ package_nvidia-vulkan-utils() {
install -D -m755 "libnvidia-rtcore.so.${pkgver}" "${pkgdir}/usr/lib/libnvidia-rtcore.so.${pkgver}"
install -D -m755 "libnvidia-cbl.so.${pkgver}" "${pkgdir}/usr/lib/libnvidia-cbl.so.${pkgver}"
+ # Optical Flow
+ install -D -m755 "libnvidia-opticalflow.so.${pkgver}" -t "${pkgdir}/usr/lib"
+
# DEBUG
install -D -m755 nvidia-debugdump "${pkgdir}/usr/bin/nvidia-debugdump"
@@ -307,6 +307,9 @@ package_lib32-nvidia-vulkan-utils() {
install -D -m755 "libnvidia-ml.so.${pkgver}" "${pkgdir}/usr/lib32/libnvidia-ml.so.${pkgver}"
install -D -m755 "libnvidia-glvkspirv.so.${pkgver}" "${pkgdir}/usr/lib32/libnvidia-glvkspirv.so.${pkgver}"
+ # Optical Flow
+ install -D -m755 "libnvidia-opticalflow.so.${pkgver}" -t "${pkgdir}/usr/lib32"
+
# VDPAU
install -D -m755 "libvdpau_nvidia.so.${pkgver}" "${pkgdir}/usr/lib32/vdpau/libvdpau_nvidia.so.${pkgver}"