summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Stryker2018-11-13 15:30:29 -0500
committerJason Stryker2018-11-13 15:30:29 -0500
commitbbfb173a9245b6a5acaaa15b3c2b0df8a7a7742b (patch)
tree77596f5652eba47d2d5158611fd24c0a0900e814
parent03c554025ab2819b50500b7c05293299725c17be (diff)
downloadaur-bbfb173a9245b6a5acaaa15b3c2b0df8a7a7742b.tar.gz
update to kernel version 4.19
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ca9d183d78..10815242fe5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,8 @@ pkgbase = nvidia-vulkan
license = custom
makedepends = libglvnd
makedepends = linux
- makedepends = linux-headers>=4.18
- makedepends = linux-headers<4.19
+ makedepends = linux-headers>=4.19
+ makedepends = linux-headers<4.20
options = !strip
source = NVIDIA-Linux-x86_64-396.54.09.run::https://developer.nvidia.com/linux-3965409
source = nvidia-drm-outputclass.conf
@@ -21,8 +21,8 @@ pkgbase = nvidia-vulkan
pkgname = nvidia-vulkan
pkgdesc = NVIDIA drivers for linux (vulkan developer branch)
- depends = linux>=4.18
- depends = linux<4.19
+ depends = linux>=4.19
+ depends = linux<4.20
depends = nvidia-vulkan-utils=396.54.09
depends = libglvnd
provides = nvidia=396.54.09
diff --git a/PKGBUILD b/PKGBUILD
index 6da79f2691b..ccb64db95f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ pkgrel=1
pkgdesc="NVIDIA drivers for linux (vulkan developer branch)"
arch=('x86_64')
url="https://developer.nvidia.com/vulkan-driver"
-makedepends=('libglvnd' 'linux' 'linux-headers>=4.18' 'linux-headers<4.19')
+makedepends=('libglvnd' 'linux' 'linux-headers>=4.19' 'linux-headers<4.20')
license=('custom')
options=('!strip')
_pkg="NVIDIA-Linux-x86_64-${pkgver}"
@@ -74,7 +74,7 @@ build() {
package_nvidia-vulkan() {
pkgdesc="NVIDIA drivers for linux (vulkan developer branch)"
- depends=('linux>=4.18' 'linux<4.19' "nvidia-vulkan-utils=${pkgver}" 'libglvnd')
+ depends=('linux>=4.19' 'linux<4.20' "nvidia-vulkan-utils=${pkgver}" 'libglvnd')
provides=("nvidia=$pkgver")
conflicts+=('nvidia')