summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadik Leshy2016-10-21 03:36:46 +0700
committerVadik Leshy2016-10-21 03:36:46 +0700
commitaac3c71bbfc264d167ef984f82bbeb16ef5bd35f (patch)
tree54eec067bdba1bcd00c88a1b3b706f887ec41e7c
downloadaur-aac3c71bbfc264d167ef984f82bbeb16ef5bd35f.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..968981f62159
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = nvidia-xrun-git
+ pkgdesc = Script to run dedicated X server with discrete nvidia graphics
+ pkgver = 0.2.2.gbf1eeab
+ pkgrel = 1
+ url = https://github.com/Witko/nvidia-xrun
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = xorg-server
+ depends = xorg-xinit
+ depends = xorg-xrandr
+ depends = nvidia
+ depends = mesa-libgl
+ depends = bbswitch
+ provides = nvidia-xrun=0.2.2.gbf1eeab
+ provides = nvidia-xrun-git=0.2.2.gbf1eeab
+ conflicts = nvidia-xrun-git
+ source = git+https://github.com/Witko/nvidia-xrun.git
+ md5sums = SKIP
+
+pkgname = nvidia-xrun-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54f8fea14682
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Viliam Ganz <viliam.ganz@gmail.com>
+_pkgname=nvidia-xrun
+pkgname=$_pkgname"-git"
+pkgver=0.2.2.gbf1eeab
+pkgrel=1
+epoch=
+pkgdesc="Script to run dedicated X server with discrete nvidia graphics"
+arch=("x86_64")
+url="https://github.com/Witko/nvidia-xrun"
+license=('GPL')
+groups=()
+depends=('xorg-server' 'xorg-xinit' 'xorg-xrandr' 'nvidia' 'mesa-libgl' 'bbswitch')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=("$_pkgname=$pkgver" "$pkgname=$pkgver")
+conflicts=("$pkgname")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/Witko/$_pkgname.git")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed "s/-/./g"
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm 644 nvidia-xorg.conf "$pkgdir/etc/X11/nvidia-xorg.conf"
+ install -Dm 644 nvidia-xinitrc "$pkgdir/etc/X11/xinit/nvidia-xinitrc"
+ install -Dm 755 nvidia-xrun "$pkgdir/usr/bin/nvidia-xrun"
+}
+md5sums=('SKIP')