summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhanghua0002021-10-13 12:40:47 +0800
committerzhanghua0002021-10-13 12:40:47 +0800
commit13b827dc8582e014561f9d27c8c3758f79683cc9 (patch)
tree2876d2f9380f02abf013cf625a96f36cf108982b
downloadaur-13b827dc8582e014561f9d27c8c3758f79683cc9.tar.gz
First release
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af653486a946
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nvim-cmp
+ pkgdesc = A completion plugin for neovim coded in Lua.
+ pkgver = 49acc84
+ pkgrel = 1
+ url = https://github.com/hrsh7th/nvim-cmp
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim
+ depends = neovim-plug
+ depends = lua
+ depends = cmp-nvim-lsp
+ depends = cmp-buffer
+ source = git+https://github.com/hrsh7th/nvim-cmp
+ sha256sums = SKIP
+
+pkgname = nvim-cmp
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5cd9f2632708
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.tar.zst
+nvim-cmp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8af220f2d265
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=nvim-cmp
+pkgver=49acc84
+pkgrel=1
+pkgdesc='A completion plugin for neovim coded in Lua.'
+arch=('any')
+url=https://github.com/hrsh7th/nvim-cmp
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim' 'neovim-plug' 'lua' 'cmp-nvim-lsp' 'cmp-buffer')
+makedepends=('git')
+source=("git+${url}")
+sha256sums=('SKIP')
+package(){
+ cd "${srcdir}/nvim-cmp"
+ mkdir -p "${pkgdir}/usr/share/nvim/runtime"
+ install -Dm644 "plugin/cmp.lua" "${pkgdir}/usr/share/nvim/runtime/plugin/cmp.lua"
+ cp -a "lua" "${pkgdir}/usr/share/nvim/runtime/"
+ cp -a "autoload" "${pkgdir}/usr/share/nvim/runtime/"
+}
+pkgver(){
+ cd "${srcdir}/nvim-cmp"
+ git rev-parse --short HEAD
+}