summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenden Hoffman2021-08-01 15:35:14 -0500
committerBrenden Hoffman2021-08-01 15:35:14 -0500
commita6627131985ff79a3d60ddba84bf8cf17a3aa798 (patch)
tree17efec7b3a31f318ced8fc33892206a205c0a4be
downloadaur-a6627131985ff79a3d60ddba84bf8cf17a3aa798.tar.gz
New aur package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6db8c09ebfd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nvim-ghost-git
+ pkgdesc = Use your text editor to write in your browser. Everything you type in the editor will be instantly updated in the browser. This is the nvim-only plugin (git version)
+ pkgver = v0.1.1.r5.g052df0c
+ pkgrel = 1
+ url = https://github.com/subnut/nvim-ghost.nvim
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = wget
+ depends = neovim
+ source = git+https://github.com/subnut/nvim-ghost.nvim.git
+ sha512sums = SKIP
+
+pkgname = nvim-ghost-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da55071ae364
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Brenden Hoffman <hbrenden@fastmail.com>
+
+pkgname=nvim-ghost-git
+_pkgname=nvim-ghost.nvim
+pkgver=v0.1.1.r5.g052df0c
+pkgrel=1
+pkgdesc="Use your text editor to write in your browser. Everything you type in the editor will be instantly updated in the browser. This is the nvim-only plugin (git version)"
+url='https://github.com/subnut/nvim-ghost.nvim'
+arch=('any')
+license=('MIT')
+depends=('neovim')
+makedepends=('git' 'wget')
+source=("git+https://github.com/subnut/nvim-ghost.nvim.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/$_pkgname
+ _pkgver=$(cat binary_version)
+ wget -O "nvim-ghost-linux.tar.gz" \
+ "https://github.com/subnut/nvim-ghost.nvim/releases/download/v0.1.1/nvim-ghost-linux.tar.gz"
+ tar xvf "nvim-ghost-linux.tar.gz"
+ rm -f "nvim-ghost-linux.tar.gz"
+ chmod +x "nvim-ghost-binary"
+ unset _pkgver
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -dm755 "${pkgdir}/usr/share/vim/vimfiles/"
+ cp -dr --no-preserve=ownership {plugin,autoload,scripts,binary_version,binary.py,.editorconfig,.flake8,.restyled.yaml,nvim-ghost-binary} \
+ "${pkgdir}/usr/share/vim/vimfiles/"
+}