summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2016-03-25 12:20:12 +1100
committerRhinoceros2016-03-25 12:20:12 +1100
commit18165e0e5cc09297f2322d2052e07416063e49bb (patch)
tree4396a7b097cd62b453584cd71b85a7c71c22853e
downloadaur-18165e0e5cc09297f2322d2052e07416063e49bb.tar.gz
Initial commit of 0.9.3-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3935bf823fb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Mar 25 01:19:51 UTC 2016
+pkgbase = nvim-r
+ pkgdesc = Vim plugin to work with R
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = https://github.com/jalvesaq/nvim-r
+ arch = any
+ license = GPL2
+ optdepends = vim>=7.4.1579: either vim or neovim
+ optdepends = tmux: if using vim, necessary for sending commands to R
+ optdepends = neovim: either neovim or vim
+ optdepends = pandoc: render output from markup files
+ optdepends = vim-csv: inspect data.frames and matrices
+ source = https://github.com/jalvesaq/Nvim-R/releases/download/v0.9.3/Nvim-R.vmb
+ sha256sums = 336acec73a4aede96cfc2974d7c7e95bccf8611208f7d9fac341cf3fa056b2cd
+
+pkgname = nvim-r
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f3e960a8391
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+
+pkgname=nvim-r
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="Vim plugin to work with R"
+arch=('any')
+url="https://github.com/jalvesaq/${pkgname}"
+license=('GPL2')
+optdepends=('vim>=7.4.1579: either vim or neovim'
+ 'tmux: if using vim, necessary for sending commands to R'
+ 'neovim: either neovim or vim'
+ 'pandoc: render output from markup files'
+ 'vim-csv: inspect data.frames and matrices')
+source=("https://github.com/jalvesaq/Nvim-R/releases/download/v${pkgver}/Nvim-R.vmb")
+sha256sums=('336acec73a4aede96cfc2974d7c7e95bccf8611208f7d9fac341cf3fa056b2cd')
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/vim/vimfiles"
+ vim -c "UseVimball ${pkgdir}/usr/share/vim/vimfiles" -c q \
+ "${srcdir}/Nvim-R.vmb"
+ rm "${pkgdir}/usr/share/vim/vimfiles/.VimballRecord"
+ rm "${pkgdir}/usr/share/vim/vimfiles/doc/tags"
+}