summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNogweii2022-08-15 23:51:54 -0700
committerNogweii2022-08-15 23:53:21 -0700
commitcec0a6a756560233986e835f08a0a16b1bbcf61e (patch)
treea37fc0e0d5d66293070cdb088e6d7540ba96b5a9
parentc0a59e07b231b512d35c743a828d985289319778 (diff)
downloadaur-cec0a6a756560233986e835f08a0a16b1bbcf61e.tar.gz
Bump nvim-treesitter-parsers-git pkgrel to 2
- Set license to Apache, which is what the upstream repo is licensed under. Will need to confirm with others if this is how it should work. - Copy the revisions along with the compiled `.so` files as is done in the normal process of the plugin
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 880f6956fc1d..9f3436b2ec81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = nvim-treesitter-parsers-git
pkgdesc = All of the registered tree sitter parsers used by Neovim
pkgver = r595.a0251c98
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/nvim-treesitter/nvim-treesitter
arch = x86_64
- license = GPL
+ license = Apache
makedepends = git
makedepends = npm
depends = tree-sitter
diff --git a/PKGBUILD b/PKGBUILD
index 13ebe69fefc8..e141acaa1925 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Nogweii <packages@nogweii.net>
pkgname=nvim-treesitter-parsers-git
pkgver=r595.a0251c98
-pkgrel=1
+pkgrel=2
pkgdesc="All of the registered tree sitter parsers used by Neovim"
arch=(x86_64)
url="https://github.com/nvim-treesitter/nvim-treesitter"
-license=('GPL')
+license=('Apache')
depends=('tree-sitter' 'neovim')
makedepends=('git' 'npm') # 'bzr', 'git', 'mercurial' or 'subversion'
provides=("${pkgname%-git}")
@@ -33,4 +33,6 @@ package() {
cd "$srcdir/${_dirname}"
mkdir -p "$pkgdir/usr/share/nvim/runtime/parser/"
cp parser/*.so -t "$pkgdir/usr/share/nvim/runtime/parser/"
+ mkdir -p "$pkgdir/usr/share/nvim/runtime/parser-info/"
+ cp parser-info/*.revision -t "$pkgdir/usr/share/nvim/runtime/parser-info/"
}