summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Kral2016-07-04 17:30:45 +0200
committerTomas Kral2016-07-04 17:30:45 +0200
commit8826a6f15b6816cd44d82d1a5a262ccb0c19b86f (patch)
tree740781d04e224fbf752844a631b43e3985381e6b
parent2d1ad7ff4e64dceb8c6b3d7624b7465926f26130 (diff)
downloadaur-8826a6f15b6816cd44d82d1a5a262ccb0c19b86f.tar.gz
fix dependencies, add desktop file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--nvpy.desktop12
3 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f4058f65f87..64324042f28c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvpy-git
pkgdesc = Simplenote syncing note-taking application, inspired by Notational Velocity and ResophNotes, but uglier and cross-platformerer.
pkgver = r430.d1c926c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cpbotha/nvpy
arch = any
license = BSD
@@ -10,11 +10,13 @@ pkgbase = nvpy-git
depends = python2-docutils
depends = python2-markdown
depends = python2-setuptools
- depends = python2-pmw
+ depends = tk
provides = nvpy
conflicts = nvpy
source = nvpy::git+https://github.com/cpbotha/nvpy.git
+ source = nvpy.desktop
md5sums = SKIP
+ md5sums = 3af5dfdda04db2262c7dfab9c0c4c681
pkgname = nvpy-git
diff --git a/PKGBUILD b/PKGBUILD
index f6161944d635..ea938c817cea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Tomas Kral <tomas.kral@gmail.com>
pkgname=nvpy-git
pkgver=r430.d1c926c
-pkgrel=1
+pkgrel=2
pkgdesc="Simplenote syncing note-taking application, inspired by Notational Velocity and ResophNotes, but uglier and cross-platformerer."
arch=("any")
url="https://github.com/cpbotha/nvpy"
license=("BSD")
-depends=("python2-docutils" "python2-markdown" "python2-setuptools" "python2-pmw")
+depends=("python2-docutils" "python2-markdown" "python2-setuptools" "tk")
makedepends=("git" "python2")
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("nvpy::git+https://github.com/cpbotha/nvpy.git")
-md5sums=("SKIP")
+source=("nvpy::git+https://github.com/cpbotha/nvpy.git" "nvpy.desktop")
+md5sums=("SKIP" "3af5dfdda04db2262c7dfab9c0c4c681")
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -23,8 +23,11 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
python2 setup.py install --root="$pkgdir/" --optimize=1
+ pwd
+ install -Dm644 "$srcdir"/nvpy.desktop "${pkgdir}"/usr/share/applications/nvpy.desktop
+
mkdir -p $pkgdir/usr/share/licenses/$pkgname
cp LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/nvpy.desktop b/nvpy.desktop
new file mode 100644
index 000000000000..6e5776d77f0c
--- /dev/null
+++ b/nvpy.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=nvPY
+Comment=Cross-platform simplenote-syncing note-taking tool
+Exec=nvpy
+Icon=/usr/lib/python2.7/site-packages/nvpy/icons/nvpy.gif
+Categories=Utility;
+Terminal=false
+StartupNotify=true
+StartupWMClass=nvPY
+