summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Kral2016-03-30 22:59:06 +0200
committerTomas Kral2016-03-30 22:59:06 +0200
commit8f34fec996eb6c70e9456acfd1e217a5d9df7ef6 (patch)
tree7ab4c4ce15ee8696ec9cb6e973416449de8c71cb
downloadaur-8f34fec996eb6c70e9456acfd1e217a5d9df7ef6.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d6a6d80002e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nvpy-git
+ pkgdesc = Simplenote syncing note-taking application, inspired by Notational Velocity and ResophNotes, but uglier and cross-platformerer.
+ pkgver = VERSION
+ pkgrel = 1
+ url = https://github.com/cpbotha/nvpy
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python2
+ depends = python2-docutils
+ depends = python2-markdown
+ provides = nvpy
+ conflicts = nvpy
+ source = nvpy::git+https://github.com/cpbotha/nvpy.git
+ md5sums = SKIP
+
+pkgname = nvpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..098fc6e33e70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tomas Kral <tomas.kral@gmail.com>
+pkgname=nvpy-git
+pkgver=VERSION
+pkgrel=1
+pkgdesc="Simplenote syncing note-taking application, inspired by Notational Velocity and ResophNotes, but uglier and cross-platformerer."
+arch=('any')
+url="https://github.com/cpbotha/nvpy"
+license=('BSD')
+depends=('python2-docutils' 'python2-markdown')
+makedepends=('git' 'python2')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=('nvpy::git+https://github.com/cpbotha/nvpy.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ cp LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}