summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLudvig Holtze2019-02-09 17:44:33 +0100
committerLudvig Holtze2019-02-09 17:44:33 +0100
commitb3db18b0ebae51d8e490b28f011c400dab6cfbfb (patch)
treedee88b2da56f710d5f937dc4f236be394ebe3398
downloadaur-b3db18b0ebae51d8e490b28f011c400dab6cfbfb.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..434e7ef1e11d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nvramtool-git
+ pkgdesc = A utility for interfacing with CMOS/NVRAM on Coreboot systems
+ pkgver = 2.1.f813b844862
+ pkgrel = 1
+ url = https://www.coreboot.org/Nvramtool
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ provides = nvramtool
+ conflicts = nvramtool
+ source = git+https://review.coreboot.org/coreboot
+ sha256sums = SKIP
+
+pkgname = nvramtool-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..522f53f300eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ludvig Holtze <ludvig dot holtze at protonmail dot com>
+
+pkgname=nvramtool-git
+pkgver=2.1.f813b844862
+pkgrel=1
+pkgdesc="A utility for interfacing with CMOS/NVRAM on Coreboot systems"
+url="https://www.coreboot.org/Nvramtool"
+license=('GPL2')
+arch=('i686' 'x86_64')
+makedepends=('git')
+conflicts=('nvramtool')
+provides=('nvramtool')
+source=('git+https://review.coreboot.org/coreboot')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/coreboot"
+ echo "2.1.$(git log -1 --format="%h")"
+}
+
+build() {
+ cd "$srcdir/coreboot/util/nvramtool"
+ make
+}
+
+package() {
+ cd "$srcdir/coreboot/util/nvramtool"
+ install -d "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man8"
+ install -m755 nvramtool "$pkgdir/usr/bin/nvramtool"
+ install -m644 cli/nvramtool.8 "$pkgdir/usr/share/man/man8"
+}