summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora.kudelin2020-09-04 19:29:15 +0300
committera.kudelin2020-09-04 19:29:15 +0300
commit2e2f962d0d9fa46cfef74e98521e3bf3a0377440 (patch)
tree0547cf3483ba3001ce1437d9c34c2c5180ebe87e
parent1c2ed477e6c6df4792013b921b9ee92edb898494 (diff)
downloadaur-2e2f962d0d9fa46cfef74e98521e3bf3a0377440.tar.gz
Improvements and fixes
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
-rw-r--r--config.sh22
3 files changed, 35 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55f0f28567ba..6b95a9c963d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = nwchem
pkgdesc = Ab initio computational chemistry software package
pkgver = 7.0.0
- pkgrel = 1
- url = http://www.nwchem-sw.org/index.php/Main_Page
+ pkgrel = 2
+ url = https://nwchemgit.github.io
install = nwchem.install
arch = x86_64
license = ECL
makedepends = gcc-fortran
depends = python
depends = scalapack
- source = https://github.com/nwchemgit/nwchem/archive/v7.0.0-release.tar.gz
+ source = nwchem-7.0.0.tar.gz::https://github.com/nwchemgit/nwchem/archive/v7.0.0-release.tar.gz
source = config.sh
source = nwchemrc
sha256sums = dc03194513a6d2deecde6e80135b68419dca35483c9ecb45e35c5a028e27b15f
- sha256sums = ae97d6dbdc2c11802b8699564ad433c4b8aef67263bbd8f4d64a549debd3b1da
+ sha256sums = 2e67032fd6175df26b9cfe543cea96befe90f6315846b6e92e231fdaf461f667
sha256sums = d63fdfc44a8f44419748e029d031c91716635ac4f062cd835014cde04677b90f
pkgname = nwchem
diff --git a/PKGBUILD b/PKGBUILD
index 7913337aea2d..69faba8006e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
-# Maintainter: Anton Kudelin <kudelin at protonmail dot com>
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
# Contributor: Scott Tincman <sctincman at gmail dot com>
pkgname=nwchem
pkgver=7.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Ab initio computational chemistry software package"
arch=('x86_64')
-url="http://www.nwchem-sw.org/index.php/Main_Page"
+url="https://nwchemgit.github.io"
license=('ECL')
depends=('python' 'scalapack')
makedepends=('gcc-fortran')
optdepends=()
install=nwchem.install
-source=("https://github.com/nwchemgit/nwchem/archive/v$pkgver-release.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nwchemgit/nwchem/archive/v$pkgver-release.tar.gz"
"config.sh"
"nwchemrc")
sha256sums=('dc03194513a6d2deecde6e80135b68419dca35483c9ecb45e35c5a028e27b15f'
- 'ae97d6dbdc2c11802b8699564ad433c4b8aef67263bbd8f4d64a549debd3b1da'
+ '2e67032fd6175df26b9cfe543cea96befe90f6315846b6e92e231fdaf461f667'
'd63fdfc44a8f44419748e029d031c91716635ac4f062cd835014cde04677b90f')
prepare(){
+ cd "$srcdir/$pkgname-$pkgver-release/src"
+
# Fix CUDA
sed -i 's/$(CUDA_FLAGS)/$(CUDA_FLAGS) --compiler-options -fPIC/g' \
- "$srcdir/$pkgname-$pkgver-release/src/config/makefile.h"
+ config/makefile.h
}
build() {
@@ -33,6 +35,17 @@ build() {
make 64_to_32
make
../contrib/getmem.nwchem
+ cd util
+ make version
+ make
+ cd ..
+ make link
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver-release/QA"
+ _corenumber=$( grep -c ^processor /proc/cpuinfo )
+ bash doqmtests.mpi 4 fast
}
package() {
diff --git a/config.sh b/config.sh
index 5591412e176b..328a1111acb3 100644
--- a/config.sh
+++ b/config.sh
@@ -1,6 +1,6 @@
-#===================================================#
-# GA Settings #
-#===================================================#
+#=======================================================================#
+# GA Settings #
+#=======================================================================#
export CC=gcc
export CXX=g++
@@ -8,12 +8,13 @@ export FC=gfortran
export F77=gfortran
export USE_MPI=yes
-
export MPI_LOC=/usr
export MPI_LIB=$MPI_LOC/lib/openmpi
export MPI_INCLUDE=$MPI_LOC/include
export LIBMPI="-lmpi_usempif08 -lmpi_usempi_ignore_tkr -lmpi_mpifh -lmpi"
+export ARMCI_NETWORK=MPI-PR
+
export USE_64TO32=y
export HAS_BLAS=yes
@@ -27,14 +28,15 @@ export SCALAPACK="-lscalapack"
export LAPACK_SIZE=4
export LAPACK_LIB="-llapack"
-#===================================================#
-# NWChem Settings #
-#===================================================#
+#=======================================================================#
+# NWChem Settings #
+#=======================================================================#
export NWCHEM_TARGET=LINUX64
export NWCHEM_MODULES="all nwxc python"
export NWCHEM_TOP=$(pwd)
+export USE_PYTHONCONFIG=y
export PYTHONHOME=/usr
export PYTHONVERSION=3.8
export PYTHONLIBTYPE=so
@@ -48,9 +50,9 @@ export CCSDTLR=y
export IPCCSD=y
export EACCSD=y
-#===================================================#
-# CUDA Settings #
-#===================================================#
+#=======================================================================#
+# CUDA Settings #
+#=======================================================================#
#export TCE_CUDA=y
#export CUDA_HOME=/opt/cuda