summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2018-12-09 16:38:08 -0500
committerEric Berquist2018-12-09 16:38:08 -0500
commite110f8973891083d355207b97d372575c0d3a5fc (patch)
tree6b34f0315f47abdea0655f856df7b536174215c9
parentece979890ea20fe3ac9f5617ba431f3872dd5520 (diff)
downloadaur-e110f8973891083d355207b97d372575c0d3a5fc.tar.gz
Fix for scalapack symbolic link, remove unneeded libgfortran dep
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49b5a327a78b..750a802c9c9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nwchem-bin
pkgdesc = Open Source High-Performance Computational Chemistry (Debian binary build)
pkgver = 6.8.47.gitdf6c956.3.b1
- pkgrel = 1
+ pkgrel = 2
url = http://www.nwchem-sw.org
arch = x86_64
license = custom:ECL2.0
@@ -10,7 +10,6 @@ pkgbase = nwchem-bin
depends = python2
depends = openmpi
depends = nwchem-data
- depends = libgfortran6
depends = scalapack
provides = nwchem
conflicts = nwchem
diff --git a/PKGBUILD b/PKGBUILD
index 01532dc7a491..95ff93b85833 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@ pkgname=${_pkgname}-bin
_pkgver=6.8+47+gitdf6c956-3+b1
_pkgver_tmp="${_pkgver//\+/\.}"
pkgver="${_pkgver_tmp//-/\.}"
-pkgrel=1
+pkgrel=2
pkgdesc="Open Source High-Performance Computational Chemistry (Debian binary build)"
arch=("x86_64")
url="http://www.nwchem-sw.org"
license=("custom:ECL2.0" "GPL3")
-depends=("lapack" "python2" "openmpi" "nwchem-data" "libgfortran6" "scalapack")
+depends=("lapack" "python2" "openmpi" "nwchem-data" "scalapack")
provides=("${_pkgname}")
conflicts=("${_pkgname}")
options=("!strip" "libtool" "staticlibs")
@@ -28,4 +28,8 @@ package() {
rm "${pkgdir}"/usr/share/doc/nwchem/changelog.*
rm "${pkgdir}"/usr/share/doc/nwchem/TODO.Debian
rm -r "${pkgdir}"/usr/share/lintian
+
+ # Don't modify the scalapack PKGBUILD.
+ mkdir -p "${pkgdir}"/usr/lib
+ ln -fsv /usr/lib/libscalapack.so "${pkgdir}"/usr/lib/libscalapack-openmpi.so.2.0
}