summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2017-02-12 19:31:27 +0100
committerJulien Nicoulaud2017-02-12 19:31:27 +0100
commitff54102936737561b5c2b92a7d7ec0b153219245 (patch)
treef43d04bb21e9db880c88d03c88bd33f903bf1559
downloadaur-ff54102936737561b5c2b92a7d7ec0b153219245.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--Changelog10
-rw-r--r--PKGBUILD21
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b538b5d7b075
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nwdiag
+ pkgdesc = Generate network-diagram image files from spec-text files.
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = http://blockdiag.com/en/nwdiag
+ changelog = Changelog
+ arch = any
+ license = APACHE
+ makedepends = python-distribute
+ depends = python
+ depends = blockdiag>=1.3.0
+ optdepends = python-reportlab: to use the PDF output format
+ conflicts = nwdiag-hg
+ source = http://pypi.python.org/packages/source/n/nwdiag/nwdiag-1.0.4.tar.gz
+ md5sums = 0d2ff1348aeff53aaf08838d0fa2c001
+
+pkgname = nwdiag
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e66f2a71ed7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar*
+*.zip
+.AURINFO
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..5e471316985a
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,10 @@
+2012-01-17 Julien Nicoulaud <julien.nicoulaud@gmail.com>
+
+ * 0.7.0-2 :
+ Fix incorrect optdepends syntax.
+
+2011-11-26 Julien Nicoulaud <julien.nicoulaud@gmail.com>
+
+ * 0.7.0-1 :
+ Initial release of the package.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfc7c2027434
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Julien Nicoulaud <julien.nicoulaud@gmail.com>
+# Source: https://github.com/nicoulaj/archlinux-packages
+pkgname=nwdiag
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Generate network-diagram image files from spec-text files."
+arch=(any)
+url="http://blockdiag.com/en/nwdiag"
+license=(APACHE)
+depends=('python' 'blockdiag>=1.3.0')
+optdepends=('python-reportlab: to use the PDF output format')
+makedepends=(python-distribute)
+changelog=Changelog
+conflicts=('nwdiag-hg')
+source=("http://pypi.python.org/packages/source/n/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('0d2ff1348aeff53aaf08838d0fa2c001')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}