summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiotr2024-01-28 03:36:44 +0100
committerpiotr2024-01-28 03:36:44 +0100
commitd1906c5591cc8765d29744c0e17c9a533a794607 (patch)
treea56b72f3d9e20b4a8d9099594354c6150dd7662b
parent1b9c46116ffb79b122b5de58b9e3ca5a45527acd (diff)
downloadaur-d1906c5591cc8765d29744c0e17c9a533a794607.tar.gz
update to 0.1.7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb209abe130f..82329eedba51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nwg-hello
pkgdesc = GTK3-based greeter for greetd written in python
- pkgver = 0.1.6
- pkgrel = 1
+ pkgver = 0.1.7
+ pkgrel = 0
url = https://github.com/nwg-piotr/nwg-hello
arch = any
license = MIT
@@ -15,7 +15,7 @@ pkgbase = nwg-hello
depends = gnome-themes-extra
optdepends = sway: this or hyprland must be installed
optdepends = hyprland: this or sway must be installed
- source = nwg-hello-0.1.6.tar.gz::https://github.com/nwg-piotr/nwg-hello/archive/v0.1.6.tar.gz
- md5sums = 6b73f21c506d6550e639ea152ab6ed91
+ source = nwg-hello-0.1.7.tar.gz::https://github.com/nwg-piotr/nwg-hello/archive/v0.1.7.tar.gz
+ md5sums = 8e49f2de026a3970652e986742f97522
pkgname = nwg-hello
diff --git a/PKGBUILD b/PKGBUILD
index 3109fd179f1d..b689443f81e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('nwg-hello')
-pkgver=0.1.6
-pkgrel=1
+pkgver=0.1.7
+pkgrel=0
pkgdesc="GTK3-based greeter for greetd written in python"
arch=('any')
url="https://github.com/nwg-piotr/nwg-hello"
@@ -12,7 +12,7 @@ optdepends=('sway: this or hyprland must be installed'
'hyprland: this or sway must be installed')
source=("$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/nwg-hello/archive/v"$pkgver".tar.gz")
-md5sums=('6b73f21c506d6550e639ea152ab6ed91')
+md5sums=('8e49f2de026a3970652e986742f97522')
package() {
cd "${pkgname}-${pkgver}"
@@ -27,5 +27,8 @@ package() {
install -d -m 755 "$pkgdir"/var/cache/nwg-hello -o greeter
install -Dm666 -t "$pkgdir"/var/cache/nwg-hello cache.json -o greeter
+ install -D -t "$pkgdir"/usr/share/licenses/"$pkgname" LICENSE
+ install -D -t "$pkgdir"/usr/share/doc/"$pkgname" README.md
+
python setup.py install --root="${pkgdir}" --optimize=1
} \ No newline at end of file