summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiotr2022-05-22 03:44:55 +0200
committerpiotr2022-05-22 03:44:55 +0200
commitb4cef79dc348bbb29a01f64f0ed97cd8480c612b (patch)
tree5e56b4a70efac2661a124f5693b9f90ad1664600
downloadaur-b4cef79dc348bbb29a01f64f0ed97cd8480c612b.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d56b6a2454e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nwg-icon-picker
+ pkgdesc = GTK icon chooser with textual search
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/nwg-piotr/nwg-icon-picker
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-gobject
+ depends = gtk3
+ source = nwg-icon-picker-0.0.1.tar.gz::https://github.com/nwg-piotr/nwg-icon-picker/archive/v0.0.1.tar.gz
+ md5sums = 7ed0b75ea5ad18ec1f69acf62e75e28c
+
+pkgname = nwg-icon-picker
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdebd6473024
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
+pkgname=('nwg-icon-picker')
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="GTK icon chooser with textual search"
+arch=('x86_64')
+url="https://github.com/nwg-piotr/nwg-icon-picker"
+license=('MIT')
+depends=('python' 'python-gobject' 'gtk3')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/nwg-icon-picker/archive/v"$pkgver".tar.gz")
+
+md5sums=('7ed0b75ea5ad18ec1f69acf62e75e28c')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -t "$pkgdir"/usr/share/pixmaps nwg-icon-picker.svg
+ install -D -t "$pkgdir"/usr/share/applications nwg-icon-picker.desktop
+} \ No newline at end of file