summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiotr2022-07-09 02:28:21 +0200
committerpiotr2022-07-09 02:28:21 +0200
commit7639f9c03f01107ac3e35c5a1cb8899288daa822 (patch)
treeeb18260743f32ff3abc258b37ee93633080c8c4d
downloadaur-7639f9c03f01107ac3e35c5a1cb8899288daa822.tar.gz
initial release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af5e453e1a47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = nwg-shell-wallpapers
+ pkgdesc = nwg-shell wallpapers package
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/nwg-piotr/nwg-shell-wallpapers
+ arch = x86_64
+ license = CC0-1.0
+ provides = nwg-shell-wallpapers
+ source = nwg-shell-wallpapers-1.0.tar.gz::https://github.com/nwg-piotr/nwg-shell-wallpapers/archive/v1.0.tar.gz
+ md5sums = 4b0840f5702c52ab4b5d5a8230ab804d
+
+pkgname = nwg-shell-wallpapers
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d8b96f44777
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
+# Project: nwg-shell for sway, https://github.com/nwg-piotr/nwg-shell
+
+pkgname=('nwg-shell-wallpapers')
+pkgver=1.0
+pkgrel=1
+pkgdesc="nwg-shell wallpapers package"
+arch=('x86_64')
+url="https://github.com/nwg-piotr/nwg-shell-wallpapers"
+license=('CC0-1.0')
+provides=('nwg-shell-wallpapers')
+
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/nwg-shell-wallpapers/archive/v"$pkgver".tar.gz")
+
+md5sums=('4b0840f5702c52ab4b5d5a8230ab804d')
+
+package() {
+ cd "$srcdir"
+ install -d "$pkgdir"/usr/share/backgrounds/nwg-shell
+ install -Dm644 "$pkgname"-"$pkgver"/wallpapers/* $pkgdir/usr/share/backgrounds/nwg-shell/
+ install -Dm644 "$pkgname"-"$pkgver"/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}