summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:01:48 +0200
committerM0Rf302015-06-17 16:01:48 +0200
commitf221c82feac83bcbdf93f791033050c547679cb8 (patch)
tree4564923d9e08ee39528ad47c7a1bf7fe232eb6ea
downloadaur-f221c82feac83bcbdf93f791033050c547679cb8.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
3 files changed, 58 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..c80b1458bb85
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = nwipe
+ pkgdesc = A fork of the dwipe command that will securely erase disks using a variety of recognised methods
+ pkgver = 0.16
+ pkgrel = 1
+ url = http://www.andybev.com/index.php/Nwipe
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = device-mapper
+ depends = ncurses
+ depends = parted
+ source = nwipe-0.16.tar.gz::http://sourceforge.net/projects/nwipe/files/nwipe-0.16.tar.gz/download
+ md5sums = 98487303370494b65df47e98649a054a
+
+pkgname = nwipe
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c80b1458bb85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nwipe
+ pkgdesc = A fork of the dwipe command that will securely erase disks using a variety of recognised methods
+ pkgver = 0.16
+ pkgrel = 1
+ url = http://www.andybev.com/index.php/Nwipe
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = device-mapper
+ depends = ncurses
+ depends = parted
+ source = nwipe-0.16.tar.gz::http://sourceforge.net/projects/nwipe/files/nwipe-0.16.tar.gz/download
+ md5sums = 98487303370494b65df47e98649a054a
+
+pkgname = nwipe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c1932e024cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: M0Rf30
+# Contributor: <kfgz at interia dot pl>
+
+pkgname=nwipe
+pkgver=0.16
+pkgrel=1
+pkgdesc="A fork of the dwipe command that will securely erase disks using a variety of recognised methods"
+arch=('i686' 'x86_64')
+url="http://www.andybev.com/index.php/Nwipe"
+depends=('device-mapper' 'ncurses' 'parted')
+license=('GPL2')
+source=(${pkgname}-${pkgver}.tar.gz::http://sourceforge.net/projects/${pkgname}/files/${pkgname}-${pkgver}.tar.gz/download)
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ ./init.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums=('98487303370494b65df47e98649a054a')