summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2015-08-29 16:04:38 -0400
committerbrent s2015-08-29 16:04:38 -0400
commit5c07118dad80ced9bb7cb60fde3cf2f4129c36f2 (patch)
tree065e7f6e7cd476e1499e02a9b0554bfd3082ee63
downloadaur-5c07118dad80ced9bb7cb60fde3cf2f4129c36f2.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..887f88d1fbdf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nwipe-git
+ pkgdesc = A fork of the dwipe command that will securely erase disks using a variety of recognised methods (from Git)
+ pkgver = r24.8a9a718
+ pkgrel = 1
+ url = http://www.andybev.com/index.php/Nwipe
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = device-mapper
+ depends = ncurses
+ depends = parted
+ source = git+https://github.com/martijnvanbrummelen/nwipe.git
+ md5sums = SKIP
+
+pkgname = nwipe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f5efe0629a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: brent s. <bts [at] square-r00t [dot] net>
+# Based on: https://aur.archlinux.org/packages/nwipe/ (by M0Rf30 <morf3089 [at] gmail [dot] com>)
+
+pkgname=nwipe-git
+_pkgname=nwipe
+pkgver=r24.8a9a718
+pkgrel=1
+pkgdesc="A fork of the dwipe command that will securely erase disks using a variety of recognised methods (from Git)"
+arch=('i686' 'x86_64')
+url="http://www.andybev.com/index.php/Nwipe"
+depends=('device-mapper' 'ncurses' 'parted')
+license=('GPL2')
+source=('git+https://github.com/martijnvanbrummelen/nwipe.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ (
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #( set -o pipefail
+ # git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ # printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #)
+ )
+}
+
+build() {
+ cd "${srcdir}"/${_pkgname}
+ ./init.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/${_pkgname}
+ make DESTDIR="${pkgdir}" install
+}
+