summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2017-07-28 13:04:25 +0200
committerJonas Heinrich2017-07-28 13:04:25 +0200
commit13c2c3c4aa214f7e286d39618296375802099847 (patch)
tree6182553bc474a84d34bd9bea16fbdab30025c079
parentd47bf24a765b6eb97785e67ef51574c3dca9e46d (diff)
downloadaur-13c2c3c4aa214f7e286d39618296375802099847.tar.gz
fixed ninja compile errors and switched back to git sources due to compile errors
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD15
2 files changed, 25 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddda9afa95d6..73583cf361d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,29 @@
# Generated by mksrcinfo v8
-# Wed Jul 26 21:22:19 UTC 2017
+# Fri Jul 28 11:02:52 UTC 2017
pkgbase = nwjs
pkgdesc = node-webkit is an app runtime based on Chromium and node.js
pkgver = 0.24.0
- pkgrel = 3
+ pkgrel = 6
url = https://nwjs.io/
arch = i686
arch = x86_64
license = MIT
makedepends = depot-tools-git
makedepends = libtinfo5
+ makedepends = python
+ makedepends = perl
+ makedepends = gperf
+ makedepends = nss
+ makedepends = alsa-lib
+ makedepends = gconf
+ makedepends = glib2
+ makedepends = gtk2
+ makedepends = nspr
+ makedepends = ttf-ms-fonts
+ makedepends = freetype2
+ makedepends = cairo
+ makedepends = dbus
+ makedepends = libgnome-keyring
depends = alsa-lib
depends = gconf
depends = gtk2
diff --git a/PKGBUILD b/PKGBUILD
index 6e5f01a0fb7e..e08ebbdbe35e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
pkgname=nwjs
pkgver=0.24.0
-pkgrel=3
+pkgrel=6
pkgdesc="node-webkit is an app runtime based on Chromium and node.js"
arch=("i686" "x86_64")
url="https://nwjs.io/"
license=("MIT")
depends=("alsa-lib" "gconf" "gtk2" "nss" "ttf-font" "libxtst" "libxss")
-makedepends=("depot-tools-git" "libtinfo5")
+makedepends=("depot-tools-git" "libtinfo5" "python" "perl" "gperf" "nss" "alsa-lib" "gconf" "glib2" "gtk2" "nspr" "ttf-ms-fonts" "freetype2" "cairo" "dbus" "libgnome-keyring")
optdepends=(
"nodejs: npm package support"
"nw-gyp: native add-on build tool for node-webkit"
@@ -34,7 +34,7 @@ prepare() {
# Removing references to git version in build config,
# since we will use the stable source tarball
- sed -i '/\"\:commit_id\"/d' "nw.js-nw-v${pkgver}/content/nw/BUILD.gn"
+ # sed -i '/\"\:commit_id\"/d' "nw.js-nw-v${pkgver}/BUILD.gn"
# Local copy of depot_tools to manage temporary write permissions
cp -r /opt/depot_tools .
@@ -52,9 +52,12 @@ build() {
gclient config --name=src https://github.com/nwjs/chromium.src.git@origin/nw24
gclient sync --with_branch_heads --nohooks
- mv "${srcdir}/nw.js-nw-v${pkgver}" src/content/nw
- mv "${srcdir}/node-nw-v${pkgver}" src/third_party/node-nw
- mv "${srcdir}/v8-nw-v${pkgver}" src/v8
+ #mv "${srcdir}/nw.js-nw-v${pkgver}" src/content/nw
+ #mv "${srcdir}/node-nw-v${pkgver}" src/third_party/node-nw
+ #mv "${srcdir}/v8-nw-v${pkgver}" src/v8
+ git clone -b nw24 https://github.com/nwjs/node.git src/third_party/node-nw
+ git clone -b nw24 https://github.com/nwjs/v8.git src/v8
+ git clone -b nw24 https://github.com/nwjs/nw.js.git src/content/nw
gclient runhooks