summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2017-07-28 13:50:25 +0200
committerJonas Heinrich2017-07-28 13:50:25 +0200
commit3a10bd1ca4af88dd70c28e202bf921d1399ef34b (patch)
tree0811e7e8f95d7f79cb5f4d3f52c1e1f6cff20ee5
parent13c2c3c4aa214f7e286d39618296375802099847 (diff)
downloadaur-3a10bd1ca4af88dd70c28e202bf921d1399ef34b.tar.gz
fixed node compile erros, fixed packaging function
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73583cf361d1..fa6089e779b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jul 28 11:02:52 UTC 2017
+# Fri Jul 28 11:49:28 UTC 2017
pkgbase = nwjs
pkgdesc = node-webkit is an app runtime based on Chromium and node.js
pkgver = 0.24.0
- pkgrel = 6
+ pkgrel = 7
url = https://nwjs.io/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e08ebbdbe35e..2a77525303a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=nwjs
pkgver=0.24.0
-pkgrel=6
+pkgrel=7
pkgdesc="node-webkit is an app runtime based on Chromium and node.js"
arch=("i686" "x86_64")
url="https://nwjs.io/"
@@ -67,16 +67,21 @@ build() {
GYP_CHROMIUM_NO_ACTION=0 ./build/gyp_chromium -I third_party/node-nw/common.gypi third_party/node-nw/node.gyp
/usr/bin/ninja -C out/nw nwjs
+
+ # Fix some wired compile errors
+ find third_party/icu -type f -exec sed -i 's/<math\.h>/<cmath>/g' {} \;
+ find third_party/node-nw ! -name 'des_locl.h' -type f -exec sed -i 's/<math\.h>/<cmath>/g' {} \;
+ export C_INCLUDE_PATH="{pkgsrc}/nwjs/src/nwjs/src/build/linux/debian_jessie_amd64-sysroot/usr/include/x86_64-linux-gnu"
+ export CPLUS_INCLUDE_PATH="{pkgsrc}/nwjs/src/build/linux/debian_jessie_amd64-sysroot/usr/include/x86_64-linux-gnu"
+
/usr/bin/ninja -C out/Release node
/usr/bin/ninja -C out/nw copy_node
}
package() {
- cd "$srcdir/$_pkgname-v$pkgver-linux-$_arch"
- install -Ddm755 "$pkgdir/opt/$_pkgname"
- install -Ddm755 "$pkgdir/usr/bin"
- chmod -R +r *
- chmod +x nw lib lib/lib{ffmpeg,node,nw}.so locales
- cp -r * "$pkgdir/opt/$_pkgname"
- ln -s "/opt/$_pkgname/nw" "$pkgdir/usr/bin/nw"
+ cd "${srcdir}/nwjs/src"
+ install -Ddm755 "${pkgdir}/var/lib/nwjs"
+ install -Ddm755 "${pkgdir}/usr/bin"
+ cp -r out/nw/{nw,lib,locales,natives_blob.bin,nw_100_percent.pak,nw_200_percent.pak,resources.pak,snapshot_blob.bin,icudtl.dat} "${pkgdir}/var/lib/nwjs/"
+ ln -s "/var/lib/nwjs/nw" "${pkgdir}/usr/bin/nw"
}