summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2017-07-25 15:04:37 +0200
committerJonas Heinrich2017-07-25 15:04:37 +0200
commit8f751ddb40fe4313c1f2bfc8a111af7d9eebdefa (patch)
tree52027ad4dbba7c68508083485f70ae703efe5953
parentecd1434ecc41a85324a8dd110e5a9080cdaf8f24 (diff)
downloadaur-8f751ddb40fe4313c1f2bfc8a111af7d9eebdefa.tar.gz
fix gclient errors in build process
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 825ac388665b..1a0ba8f6118f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jul 23 09:00:54 UTC 2017
+# Tue Jul 25 13:04:32 UTC 2017
pkgbase = nwjs
pkgdesc = node-webkit is an app runtime based on Chromium and node.js
pkgver = 0.23.6
- pkgrel = 3
+ pkgrel = 4
url = https://nwjs.io/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d34c4e7bb7b8..691f2d75720d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,12 @@
# Maintainer: Jonas Heinrich <onny@project-insanity.org>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# ToDo: Enable propretary codec
+# Bugs: Permission issue, wants to write to /opt/depot_tools/external_bin chmod -R a+w :/
+
pkgname=nwjs
pkgver=0.23.6
-pkgrel=3
+pkgrel=4
pkgdesc="node-webkit is an app runtime based on Chromium and node.js"
arch=("i686" "x86_64")
url="https://nwjs.io/"
@@ -38,7 +41,23 @@ build() {
export PATH="${srcdir}/path:$PATH"
gclient config --name=src https://github.com/nwjs/chromium.src.git@origin/nw17
+ gclient sync --with_branch_heads --nohooks
+
+ mv "${srcdir}/nw.js-nw-v${pkgver}" src/content/nw
+ mv "${srcdir}/node-nw-v${pkgver}" src/third_party/node-nw
+ mv "${srcdir}/v8-nw-v${pkgver}" src/v8
+
gclient sync --with_branch_heads
+
+ cd src
+ gn gen out/nw
+
+ GYP_CHROMIUM_NO_ACTION=0 ./build/gyp_chromium -I third_party/node-nw/common.gypi third_party/node-nw/node.gyp
+
+ ninja -C out/nw nwjs
+ ninja -C out/Release node
+ ninja -C out/nw copy_node
+
}
package() {