summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2017-07-26 22:10:01 +0200
committerJonas Heinrich2017-07-26 22:10:01 +0200
commitd69882d63d4c6e1f7d5d64910e92be638fe0d2c0 (patch)
tree8e245955a485b9a0cdba8891c10ac488c22b1afc
parent77c90f36cad00b9db9c5bf758c2c1948b2a3e1bc (diff)
downloadaur-d69882d63d4c6e1f7d5d64910e92be638fe0d2c0.tar.gz
fixed ninja compile errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa5964c5a58a..57ecc9c6b40d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Jul 26 16:08:01 UTC 2017
+# Wed Jul 26 20:09:52 UTC 2017
pkgbase = nwjs
pkgdesc = node-webkit is an app runtime based on Chromium and node.js
pkgver = 0.24.0
- pkgrel = 1
+ pkgrel = 2
url = https://nwjs.io/
arch = i686
arch = x86_64
license = MIT
makedepends = depot-tools-git
+ makedepends = libtinfo5
depends = alsa-lib
depends = gconf
depends = gtk2
diff --git a/PKGBUILD b/PKGBUILD
index 3db22328b384..fa8553177699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
pkgname=nwjs
pkgver=0.24.0
-pkgrel=1
+pkgrel=2
pkgdesc="node-webkit is an app runtime based on Chromium and node.js"
arch=("i686" "x86_64")
url="https://nwjs.io/"
license=("MIT")
depends=("alsa-lib" "gconf" "gtk2" "nss" "ttf-font" "libxtst" "libxss")
-makedepends=("depot-tools-git")
+makedepends=("depot-tools-git" "libtinfo5")
optdepends=(
"nodejs: npm package support"
"nw-gyp: native add-on build tool for node-webkit"
@@ -28,8 +28,14 @@ sha512sums=("97ec6f8c1bfd9b5dcec2edaf84a546a7d88572f127fab0dbdda4b85ee5c19caf798
prepare() {
cd "${srcdir}/"
+
+ # Fix forced Python2 requirement
mkdir -p path
ln -s /usr/bin/python2 path/python
+
+ # Removing references to git version in build config,
+ # since we will use the stable source tarball
+ sed -i '/\"\:commit_id\"/d' "nw.js-nw-v${pkgver}/content/nw/BUILD.gn"
}
build() {
@@ -39,25 +45,25 @@ build() {
export PATH="/opt/depot_tools:$PATH"
export PATH="${srcdir}/path:$PATH"
+ export GYP_DEFINES="target_arch=x64"
- gclient config --name=src https://github.com/nwjs/chromium.src.git@origin/nw17
+ gclient config --name=src https://github.com/nwjs/chromium.src.git@origin/nw24
gclient sync --with_branch_heads --nohooks
mv "${srcdir}/nw.js-nw-v${pkgver}" src/content/nw
mv "${srcdir}/node-nw-v${pkgver}" src/third_party/node-nw
mv "${srcdir}/v8-nw-v${pkgver}" src/v8
- gclient sync --with_branch_heads
+ gclient runhooks
cd src
gn gen out/nw --args='is_debug=false is_component_ffmpeg=true target_cpu="x64"'
GYP_CHROMIUM_NO_ACTION=0 ./build/gyp_chromium -I third_party/node-nw/common.gypi third_party/node-nw/node.gyp
- ninja -C out/nw nwjs
- ninja -C out/Release node
- ninja -C out/nw copy_node
-
+ /usr/bin/ninja -C out/nw nwjs
+ /usr/bin/ninja -C out/Release node
+ /usr/bin/ninja -C out/nw copy_node
}
package() {