summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-04-06 19:57:38 +0800
committerYen Chi Hsuan2016-04-06 19:57:38 +0800
commit7d88a23b9a2a718e4b1d6882687918fb3f26e82f (patch)
treec7ebb7fcbad6ed3c4bc5bba1f6f67453a1d04e84
parentc6c39b499dfa45704f746c604834a43a9587671f (diff)
downloadaur-7d88a23b9a2a718e4b1d6882687918fb3f26e82f.tar.gz
Bump to 0.13.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc8b5d60a786..8ce6406469ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Apr 6 11:57:24 UTC 2016
pkgbase = nwjs-bin
pkgdesc = node-webkit is an app runtime based on Chromium and node.js.
- pkgver = 0.12.3
+ pkgver = 0.13.3
pkgrel = 1
url = https://github.com/nwjs/nw.js
arch = i686
@@ -11,6 +13,8 @@ pkgbase = nwjs-bin
depends = gtk2
depends = nss
depends = ttf-font
+ depends = libxtst
+ depends = libxss
optdepends = nodejs: npm package support
optdepends = nw-gyp: native add-on build tool for node-webkit
provides = node-webkit
@@ -18,10 +22,10 @@ pkgbase = nwjs-bin
conflicts = node-webkit
conflicts = nwjs
replaces = node-webkit
- source_i686 = http://dl.nwjs.io/v0.12.3/nwjs-v0.12.3-linux-ia32.tar.gz
- sha256sums_i686 = 8c20f35fd5cba934c750e8dd04448b3aa472bd63cb6ff13c31cab325bde9ef84
- source_x86_64 = http://dl.nwjs.io/v0.12.3/nwjs-v0.12.3-linux-x64.tar.gz
- sha256sums_x86_64 = cfeb2e969ff4fd2e3cbe87855fba637b27f45790b2ae7549e90ca1d08bbdb1c4
+ source_i686 = http://dl.nwjs.io/v0.13.3/nwjs-v0.13.3-linux-ia32.tar.gz
+ sha256sums_i686 = 08f0aaafe73b3eb100c1961f95deb6fda240d8992f2d707e57f4840eba6efd06
+ source_x86_64 = http://dl.nwjs.io/v0.13.3/nwjs-v0.13.3-linux-x64.tar.gz
+ sha256sums_x86_64 = f056d9f4c2296a8266f89bb109e6626733bf807cd8840c33db0ea3356500e5d6
pkgname = nwjs-bin
diff --git a/PKGBUILD b/PKGBUILD
index 71c523438128..9ae17eeb1be7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Yen Chi Hsuan <yan12125 at gmail.com>
_pkgname=nwjs
pkgname=$_pkgname-bin
-pkgver=0.12.3
+pkgver=0.13.3
pkgrel=1
pkgdesc="node-webkit is an app runtime based on Chromium and node.js."
arch=("i686" "x86_64")
url="https://github.com/nwjs/nw.js"
license=("MIT")
-depends=("alsa-lib" "gconf" "gtk2" "nss" "ttf-font")
+depends=("alsa-lib" "gconf" "gtk2" "nss" "ttf-font" "libxtst" "libxss")
optdepends=(
"nodejs: npm package support"
"nw-gyp: native add-on build tool for node-webkit"
@@ -25,16 +25,15 @@ fi
source_common="http://dl.nwjs.io/v$pkgver/$_pkgname-v$pkgver-linux"
source_i686=("$source_common-ia32.tar.gz")
source_x86_64=("$source_common-x64.tar.gz")
-sha256sums_i686=("8c20f35fd5cba934c750e8dd04448b3aa472bd63cb6ff13c31cab325bde9ef84")
-sha256sums_x86_64=("cfeb2e969ff4fd2e3cbe87855fba637b27f45790b2ae7549e90ca1d08bbdb1c4")
+sha256sums_i686=("08f0aaafe73b3eb100c1961f95deb6fda240d8992f2d707e57f4840eba6efd06")
+sha256sums_x86_64=("f056d9f4c2296a8266f89bb109e6626733bf807cd8840c33db0ea3356500e5d6")
package() {
cd "$srcdir/$_pkgname-v$pkgver-linux-$_arch"
install -Ddm755 "$pkgdir/opt/$_pkgname"
install -Ddm755 "$pkgdir/usr/bin"
- chmod -R -x *
- chmod +x nw nwjc libffmpegsumo.so locales
+ chmod -R +r *
+ chmod +x nw lib lib/lib{ffmpeg,node,nw}.so locales
cp -r * "$pkgdir/opt/$_pkgname"
ln -s "/opt/$_pkgname/nw" "$pkgdir/usr/bin/nw"
- ln -s "/opt/$_pkgname/nwjc" "$pkgdir/usr/bin/nwjc"
}