summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-07-13 23:13:56 +0430
committerMohammadreza Abdollahzadeh2018-07-13 23:13:56 +0430
commitae3fcd13cf0254a70130381536b055a25b5068cf (patch)
tree65491dc377b98dd09f1eb6dde49167d265d6c765
parent0b9c87b1ef232ef3c86b70278a37c8633487c5b5 (diff)
downloadaur-ae3fcd13cf0254a70130381536b055a25b5068cf.tar.gz
update to v0.31.5
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 23 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ee714d4cd60..96a6f64d6dae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Fri Jul 13 18:43:42 UTC 2018
pkgbase = nwjs-bin
- pkgdesc = node-webkit is an app runtime based on Chromium and node.js.
- pkgver = 0.31.4
+ pkgdesc = An app runtime based on Chromium and node.js.
+ pkgver = 0.31.5
pkgrel = 1
url = https://nwjs.io/
- arch = i686
arch = x86_64
license = MIT
depends = alsa-lib
@@ -15,15 +16,13 @@ pkgbase = nwjs-bin
depends = libxss
optdepends = nodejs: npm package support
optdepends = nw-gyp: native add-on build tool for node-webkit
- provides = node-webkit
provides = nwjs
- conflicts = node-webkit
+ provides = node-webkit
conflicts = nwjs
+ conflicts = node-webkit
replaces = node-webkit
- source_i686 = http://dl.nwjs.io/v0.31.4/nwjs-v0.31.4-linux-ia32.tar.gz
- sha512sums_i686 = 2cf91865c8708143c7a880efd18f8896365157f47204f10ce6eb9a5f59b18902e5ea385f713c200e1287e32737eff987a2ebb54db43d5d2eb082bac0b0a82482
- source_x86_64 = http://dl.nwjs.io/v0.31.4/nwjs-v0.31.4-linux-x64.tar.gz
- sha512sums_x86_64 = a27295d7ecd6f3555e99475483e08f28033fbca32eed25e219ed744ceeb9938d7dd9c2e2688ddc878c21e0773c224a361be38418a4cd0052299de0eccf7fe019
+ source = http://dl.nwjs.io/v0.31.5/nwjs-v0.31.5-linux-x64.tar.gz
+ sha512sums = f0b1c4ce99a463a74cc76cd6f75955502897c28708489a2df174e8dd75b11f1ab1a1b032de5dfdc38d213952b8f5dd9b58f9bc8d54eb150263a85997e1622b5b
pkgname = nwjs-bin
diff --git a/PKGBUILD b/PKGBUILD
index 36fd2ff7a50a..74cc6f56ab57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
-# Maintainer: Josia Roßkopf <josia-login@rosskopfs.de>
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Contributor: Josia Roßkopf <josia-login@rosskopfs.de>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
# Contributor: Yen Chi Hsuan <yan12125 at gmail.com>
_pkgname=nwjs
pkgname=$_pkgname-bin
-pkgver=0.31.4
+pkgver=0.31.5
pkgrel=1
-pkgdesc="node-webkit is an app runtime based on Chromium and node.js."
-arch=("i686" "x86_64")
+pkgdesc="An app runtime based on Chromium and node.js."
+arch=("x86_64")
url="https://nwjs.io/"
license=("MIT")
depends=("alsa-lib" "gconf" "gtk2" "nss" "ttf-font" "libxtst" "libxss")
@@ -15,28 +17,17 @@ optdepends=(
"nodejs: npm package support"
"nw-gyp: native add-on build tool for node-webkit"
)
-provides=("node-webkit" "nwjs")
+provides=("nwjs" "node-webkit")
replaces=("node-webkit")
-conflicts=("node-webkit" "nwjs")
-
-if [ "$CARCH" = "i686" ]; then
- _arch="ia32"
-fi
-if [ "$CARCH" = "x86_64" ]; then
- _arch="x64"
-fi
-source_common="http://dl.nwjs.io/v$pkgver/$_pkgname-v$pkgver-linux"
-source_i686=("$source_common-ia32.tar.gz")
-source_x86_64=("$source_common-x64.tar.gz")
-sha512sums_i686=('2cf91865c8708143c7a880efd18f8896365157f47204f10ce6eb9a5f59b18902e5ea385f713c200e1287e32737eff987a2ebb54db43d5d2eb082bac0b0a82482')
-sha512sums_x86_64=('a27295d7ecd6f3555e99475483e08f28033fbca32eed25e219ed744ceeb9938d7dd9c2e2688ddc878c21e0773c224a361be38418a4cd0052299de0eccf7fe019')
+conflicts=("nwjs" "node-webkit")
+source=("http://dl.nwjs.io/v$pkgver/$_pkgname-v$pkgver-linux-x64.tar.gz")
+sha512sums=('f0b1c4ce99a463a74cc76cd6f75955502897c28708489a2df174e8dd75b11f1ab1a1b032de5dfdc38d213952b8f5dd9b58f9bc8d54eb150263a85997e1622b5b')
package() {
- cd "$srcdir/$_pkgname-v$pkgver-linux-$_arch"
- install -Ddm755 "$pkgdir/opt/$_pkgname"
- install -Ddm755 "$pkgdir/usr/bin"
- chmod -R +r *
- chmod +x nw lib lib/lib{ffmpeg,node,nw}.so locales
- cp -r * "$pkgdir/opt/$_pkgname"
+ cd "$srcdir/$_pkgname-v$pkgver-linux-x64"
+ install -d "$pkgdir/opt/$_pkgname"
+ install -d "$pkgdir/usr/bin"
+ cp -a * "$pkgdir/opt/$_pkgname"
ln -s "/opt/$_pkgname/nw" "$pkgdir/usr/bin/nw"
}
+# vim:set ts=2 sw=2 et: