summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomebody12342022-07-27 01:01:07 +1000
committersomebody12342022-07-27 01:01:07 +1000
commitac7223e50f8eb4b68e68335e92e17cb301715c63 (patch)
tree96ff3a7a4935414702d76a2514f77f766f524b34
parent51f1e46a50be03c023055fd962269bee54a19c30 (diff)
downloadaur-ac7223e50f8eb4b68e68335e92e17cb301715c63.tar.gz
feat: it's back with a copy-paste from nwjs-bin, v0.66.1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 27 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bdf480dbd1f..ba0bc1148d8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nwjs-sdk-bin
- pkgdesc = An app runtime based on Chromium and node.js (SDK version).
- pkgver = 0.36.1
+ pkgdesc = node-webkit is an app runtime based on Chromium and node.js. SDK release with DevTools
+ pkgver = 0.66.1
pkgrel = 1
url = https://nwjs.io/
arch = x86_64
@@ -10,13 +10,9 @@ pkgbase = nwjs-sdk-bin
depends = libxss
optdepends = nodejs: npm package support
optdepends = nw-gyp: native add-on build tool for node-webkit
- provides = nwjs
- provides = node-webkit
- conflicts = nwjs
- conflicts = node-webkit
- options = !strip
- source = nwjs-sdk-bin-0.36.1.tar.gz::http://dl.nwjs.io/v0.36.1/nwjs-sdk-v0.36.1-linux-x64.tar.gz
- sha256sums = ab9da4aff7863790c553253b6f15722f00561276c86a2ddae8cd441676a2a390
+ provides = nwjs-sdk
+ conflicts = nwjs-sdk
+ source = nwjs-sdk-bin-0.66.1.tar.gz::http://dl.nwjs.io/v0.66.1/nwjs-sdk-v0.66.1-linux-x64.tar.gz
+ sha512sums = e75cd3f68b72514f3810f7d32ef592772d93fed8752a10a8a471b7e674f3606903ce3c6d89e7bd496ba6e3eed6c27944fd225c9771b298e6f090a812fb16469d
pkgname = nwjs-sdk-bin
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7f4dadae9533
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 2ef3d4a7aa00..d76ab0bc0880 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,13 @@
-# $Id$
-# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Maintainer: E-Hern Lee <ehern.lee@gmail.com>
+# Contributor: Jake <aur@ja-ke.tech>
+# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Contributor: Josia Roßkopf <josia-login@rosskopfs.de>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Yen Chi Hsuan <yan12125 at gmail.com>
pkgname=nwjs-sdk-bin
-pkgver=0.36.1
+pkgver=0.66.1
pkgrel=1
-pkgdesc="An app runtime based on Chromium and node.js (SDK version)."
+pkgdesc="node-webkit is an app runtime based on Chromium and node.js. SDK release with DevTools"
arch=("x86_64")
url="https://nwjs.io/"
license=("MIT")
@@ -12,18 +16,19 @@ optdepends=(
"nodejs: npm package support"
"nw-gyp: native add-on build tool for node-webkit"
)
-options=(!strip)
-provides=("nwjs" "node-webkit")
-conflicts=("nwjs" "node-webkit")
+provides=("nwjs-sdk")
+conflicts=("nwjs-sdk")
source=("${pkgname}-${pkgver}.tar.gz::http://dl.nwjs.io/v${pkgver}/${pkgname%-bin}-v${pkgver}-linux-x64.tar.gz")
-sha256sums=('ab9da4aff7863790c553253b6f15722f00561276c86a2ddae8cd441676a2a390')
+sha512sums=('e75cd3f68b72514f3810f7d32ef592772d93fed8752a10a8a471b7e674f3606903ce3c6d89e7bd496ba6e3eed6c27944fd225c9771b298e6f090a812fb16469d')
package() {
cd "${pkgname%-bin}-v${pkgver}-linux-x64"
+
install -d "${pkgdir}/opt/${pkgname%-bin}"
+ cp -dr * "${pkgdir}/opt/${pkgname%-bin}/"
+ chmod -R 644 "${pkgdir}/opt/${pkgname%-bin}/"
+ chmod 755 "${pkgdir}/opt/${pkgname%-bin}/"{,swiftshader,lib,locales,nw,chrome_crashpad_handler,nacl_helper}
+
install -d "${pkgdir}/usr/bin"
- cp -a * "${pkgdir}/opt/${pkgname%-bin}"
- ln -s "/opt/${pkgname%-bin}/nw" "${pkgdir}/usr/bin/nw"
- ln -s "/opt/${pkgname%-bin}/nwjc" "${pkgdir}/usr/bin/nwjc"
+ ln -s "/opt/${pkgname%-bin}/nw" "${pkgdir}/usr/bin/nw-sdk"
}
-# vim:set ts=2 sw=2 et: