summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-05-13 20:47:02 -0600
committergustawho2021-05-13 20:47:02 -0600
commitd2603fd14950239b67fff67324bceb955bd67bc8 (patch)
treec07545b05273cf5d64eb9863e1d6bbbfc9f86cca
parentdcd5304687d5b65a625667d6062785639350d745 (diff)
downloadaur-d2603fd14950239b67fff67324bceb955bd67bc8.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9ebcf05c194..718d1c63233a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = nx-kwin-decoration-git
pkgdesc = KWin decoration for NX Desktop, by Nitrux SA.
- pkgver = r85.9579027
+ pkgver = r86.2ad4ec3
pkgrel = 1
url = https://github.com/nx-desktop/nx-window-deco
arch = x86_64
license = GPL3
makedepends = git
makedepends = extra-cmake-modules
+ makedepends = qt5-tools
depends = kcoreaddons
depends = kguiaddons
depends = kconfigwidgets
diff --git a/PKGBUILD b/PKGBUILD
index e80cc5a5755f..6534195acdd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=nx-kwin-decoration-git
-pkgver=r85.9579027
+pkgver=r86.2ad4ec3
pkgrel=1
pkgdesc="KWin decoration for NX Desktop, by Nitrux SA."
arch=(x86_64)
@@ -9,7 +9,7 @@ url="https://github.com/nx-desktop/nx-window-deco"
license=(GPL3)
depends=('kcoreaddons' 'kguiaddons' 'kconfigwidgets' 'kwindowsystem'
'ki18n' 'kiconthemes' 'qt5-x11extras')
-makedepends=('git' 'extra-cmake-modules')
+makedepends=('git' 'extra-cmake-modules' 'qt5-tools')
provides=('nx-kwin-decoration' 'nomad-kwin-decoration' 'nx-window-deco')
conflicts=('nx-kwin-decoration' 'nomad-kwin-decoration' 'nx-window-deco')
source=("git+${url}.git")
@@ -24,10 +24,10 @@ pkgver() {
}
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build -S nx-window-deco
- make -C build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S nx-window-deco
+ cmake --build build --config RelWithDebInfo
}
package() {
- make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file