summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRainhard Weidlinger2023-10-16 23:17:03 +0200
committerRainhard Weidlinger2023-10-16 23:17:03 +0200
commit43de420d82181bd96f1781d0300c8fc8d281b1a6 (patch)
tree51aab6d39547dc3befbefdfd25985dc2f3ff6ed2
downloadaur-43de420d82181bd96f1781d0300c8fc8d281b1a6.tar.gz
patch for extra/kvantum and initial commit as new package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eaeabe43da52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = nx-plasma-look-and-feel-compat-git
+ pkgdesc = NX Look and Feel package, patched for use with extra/kvantum
+ pkgver = r204.7d541de
+ pkgrel = 1
+ url = https://github.com/nx-desktop
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ depends = plasma-desktop
+ depends = luv-icon-theme-git
+ depends = kvantum
+ optdepends = nx-gtk-themes-git
+ conflicts = nomad-plasma-look-and-feel-git
+ replaces = nomad-plasma-look-and-feel-git
+ source = git+https://github.com/nx-desktop/nx-plasma-look-and-feel.git
+ source = git+https://github.com/nx-desktop/nx-kvantum-theme
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = nx-plasma-look-and-feel-compat-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3776aacbf546
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+
+# Maintainer: tristanrw
+
+pkgname=nx-plasma-look-and-feel-compat-git
+_gitname=nx-plasma-look-and-feel
+pkgver=r204.7d541de
+pkgrel=1
+pkgdesc="NX Look and Feel package, patched for use with extra/kvantum"
+arch=('any')
+url="https://github.com/nx-desktop"
+license=('GPL')
+replaces=('nomad-plasma-look-and-feel-git')
+conflicts=('nomad-plasma-look-and-feel-git')
+depends=('plasma-desktop' 'luv-icon-theme-git' 'kvantum')
+optdepends=('nx-gtk-themes-git')
+makedepends=('git' 'cmake' 'extra-cmake-modules')
+source=("git+${url}/nx-plasma-look-and-feel.git"
+ "git+${url}/nx-kvantum-theme")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+
+ cd ${srcdir}/${_gitname}
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+
+ cd ${srcdir}/${_gitname}
+
+ mkdir build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+}
+
+package() {
+
+ make -C ${srcdir}/${_gitname}/build DESTDIR=${pkgdir} install
+ mkdir -p ${pkgdir}/usr/share/Kvantum/{KvNitrux,KvNitruxDark}
+ cp -r ${srcdir}/nx-kvantum-theme/themes/{KvNitrux,KvNitruxDark} ${pkgdir}/usr/share/Kvantum/
+
+}