summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2023-11-07 17:14:10 +1000
committergameslayer2023-11-07 17:14:10 +1000
commitd4518d426e38ca3ffc3eebed7fdb8bc78036f1ee (patch)
tree79c7bff40146e94bcdb7d967e6c6f9917f0b1c65
downloadaur-d4518d426e38ca3ffc3eebed7fdb8bc78036f1ee.tar.gz
committing PKG file to AUR
-rw-r--r--.SRCINFO27
-rwxr-xr-xPKGBUILD30
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4398d5dddd8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = nxengine-evo-bin
+ pkgdesc = Modern open source Engine to play CaveStory
+ pkgver = 2.6.5
+ pkgrel = 1
+ url = https://github.com/diasurgical/-/raw/main/nxengine-evo-
+ arch = x86_64
+ arch = i386
+ arch = i686
+ arch = aarch64
+ license = GPL
+ makedepends = unzip
+ depends = sdl2
+ depends = sdl2_image
+ depends = libpng
+ depends = libjpeg
+ conflicts = nxengine-evo
+ conflicts = nxengine-evo-git
+ source_x86_64 = https://gitlab.com/cavestory-bin/nxengine-evo-bin/2.6.5-1/-/raw/main/nxengine-evo-linux-x64.tar.xz
+ sha256sums_x86_64 = SKIP
+ source_i386 = https://gitlab.com/cavestory-bin/nxengine-evo-bin/2.6.5-1/-/raw/main/nxengine-evo-linux-i386.tar.xz
+ sha256sums_i386 = SKIP
+ source_i686 = https://gitlab.com/cavestory-bin/nxengine-evo-bin/2.6.5-1/-/raw/main/nxengine-evo-linux-i386.tar.xz
+ sha256sums_i686 = SKIP
+ source_aarch64 = https://gitlab.com/cavestory-bin/nxengine-evo-bin/2.6.5-1/-/raw/main/nxengine-evo-linux-aarch64.tar.xz
+ sha256sums_aarch64 = SKIP
+
+pkgname = nxengine-evo-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..1e455bc3647c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=nxengine-evo-bin
+pkgver=2.6.5
+pkgrel=1
+_pkgrel_x86_64=1
+_pkgrel_i386=1
+_pkgrel_i686=1
+_pkgrel_aarch64=1
+pkgdesc="Modern open source Engine to play CaveStory"
+arch=('x86_64' 'i386' 'i686' 'aarch64')
+url="https://github.com/diasurgical/-/raw/main/nxengine-evo-"
+conflicts=("nxengine-evo" "nxengine-evo-git")
+license=('GPL')
+depends=('sdl2' 'sdl2_image' 'libpng' 'libjpeg')
+makedepends=('unzip')
+sha256sums_x86_64=('SKIP')
+sha256sums_i386=('SKIP')
+sha256sums_i686=('SKIP')
+sha256sums_aarch64=('SKIP')
+source_x86_64=("https://gitlab.com/cavestory-bin/nxengine-evo-bin/$pkgver-$pkgrel/-/raw/main/nxengine-evo-linux-x64.tar.xz")
+source_i386=("https://gitlab.com/cavestory-bin/nxengine-evo-bin/$pkgver-$pkgrel/-/raw/main/nxengine-evo-linux-i386.tar.xz")
+source_i686=("https://gitlab.com/cavestory-bin/nxengine-evo-bin/$pkgver-$pkgrel/-/raw/main/nxengine-evo-linux-i386.tar.xz")
+source_aarch64=("https://gitlab.com/cavestory-bin/nxengine-evo-bin/$pkgver-$pkgrel/-/raw/main/nxengine-evo-linux-aarch64.tar.xz")
+
+
+package() {
+ install -dm755 "$pkgdir/usr/local/share/games/nxengine-evo"
+ install -dm755 "$pkgdir/usr/bin"
+ cp -r $srcdir/nxengine-evo $pkgdir/usr/local/share/games/nxengine-evo
+ ln -sf $pkgdir/usr/local/share/games/nxengine-evo/nxengine-evo $pkgdir/usr/bin/nxengine-evo
+} \ No newline at end of file