summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwinovitch2017-07-05 00:46:20 +0200
committererwinovitch2017-07-05 00:46:20 +0200
commitc46c3a97e05def2bb7885ef665f06c1e2afa14bf (patch)
tree1f036ac5510921de97f601fd0a47eb1deaa4749b
downloadaur-c46c3a97e05def2bb7885ef665f06c1e2afa14bf.tar.gz
Primary upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--nxfilter.install7
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bb9e0c92905
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nxfilter
+ pkgdesc = NxFilter DNS filter
+ pkgver = 4.1.3
+ pkgrel = 1
+ url = http://nxfilter.org/p3/
+ install = nxfilter.install
+ arch = x86_64
+ license = custom
+ depends = java-runtime
+ depends = unzip
+ provides = nxfilter
+ source = https://github.com/Erwinovitch/NxFilter/archive/master.zip
+ md5sums = ab6b75807e71046d3cf88e262161aad6
+
+pkgname = nxfilter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f8f5c6586b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Erwin
+pkgname=nxfilter
+pkgver=4.1.3
+pkgrel=1
+pkgdesc="NxFilter DNS filter"
+arch=('x86_64')
+url=http://nxfilter.org/p3/
+license=('custom')
+depends=('java-runtime' 'unzip')
+provides=("nxfilter")
+source=("https://github.com/Erwinovitch/NxFilter/archive/master.zip")
+install='nxfilter.install'
+md5sums=('ab6b75807e71046d3cf88e262161aad6')
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr"
+
+ # Provides the init script for those whom need it
+ cp -dr --no-preserve=ownership "$srcdir/NxFilter-master/etc" "$pkgdir"
+
+ # Provides the systemd scripts
+ cp -dr --no-preserve=ownership "$srcdir/NxFilter-master/lib" "$pkgdir/usr"
+
+ # Provides the program itself
+ cp -dr --no-preserve=ownership "$srcdir/NxFilter-master/nxfilter" "$pkgdir"
+}
diff --git a/nxfilter.install b/nxfilter.install
new file mode 100644
index 000000000000..523a760c7780
--- /dev/null
+++ b/nxfilter.install
@@ -0,0 +1,7 @@
+post_install() {
+ chown $USER:$USER -R /nxfilter
+ chmod 755 /nxfilter/bin/*.sh
+}
+post_remove() {
+ rm -r /nxfilter
+}