summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2015-06-19 00:04:10 -0400
committerDavid Parrish2015-06-19 00:04:10 -0400
commit0a7f0bf97dbec068cb14a8ef7cc87ed63bb8bdb8 (patch)
treef3933136b64608d0cb17704ddb9e61a22eea29a3
parent6a69f883b7e246c5c5183a814de10b92ed93bfe4 (diff)
downloadaur-0a7f0bf97dbec068cb14a8ef7cc87ed63bb8bdb8.tar.gz
Add licenses
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4edbf81e52e..b525eff9a305 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,10 @@ pkgbase = nxt-git
url = http://nxt.org
install = nxt.install
arch = any
- license = MIT/GPL
+ license = MIT
+ license = GPL
+ license = MPL
+ license = APACHE
makedepends = java-environment-openjdk=8
depends = bash
depends = java-runtime-openjdk=8
diff --git a/PKGBUILD b/PKGBUILD
index 18944f3981c0..4379bd896310 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="The Nxt Reference Software Client for use with the Nxt Cryptocurrency."
arch=('any')
url="http://nxt.org"
-license=('MIT/GPL')
+license=('MIT' 'GPL' 'MPL' 'APACHE')
depends=('bash' 'java-runtime-openjdk=8')
makedepends=('java-environment-openjdk=8')
optdepends=('flashplugin: for add to clipboard support')
@@ -29,10 +29,15 @@ build() {
}
package() {
- # Copy to /opt/nxt
+ # Copy everything to /opt/nxt
install -dm755 "$pkgdir/opt/nxt"
cp -r "${pkgname}"/* "$pkgdir"/opt/nxt/
- # Copy service file
- install -Dm644 nxt.service "$pkgdir/usr/lib/systemd/system/nxt.service"
+ # Service file
+ install -Dm644 nxt.service "$pkgdir/usr/lib/systemd/system/nxt.service"
+
+ # License files
+ install -Dm644 "${pkgname}/COPYING.txt" "$pkgdir/usr/share/licenses/nxt/COPYING.txt"
+ install -Dm644 "${pkgname}/3RD-PARTY-LICENSES.txt" "$pkgdir/usr/share/licenses/nxt/3RD-PARTY-LICENSES.txt"
+ install -Dm644 "${pkgname}/LICENSE.txt" "$pkgdir/usr/share/licenses/nxt/LICENSES.txt"
}